Answered
0
0

Here is my setup, per FMOD’s official training videos:

https://www.youtube.com/watch?v=Z5L7wDc8MOI

If I use Oculus Spatializer, no matter what I do, 3D scatterer sound stops playing shortly after I press play in the Events Editor (sometimes it actually goes into first loop, but then stops playing). Same goes for Sandbox and actual game (PIE or device). By stops playing I mean I don’t hear any sound, while the marker on the timeline keeps running in loops. Logs don’t show any related errors or warnings.

If I use FMOD’s 3D panner, scatterer sound plays endlessly in the Event Studio and Sandbox, as it suppose to (didn’t pay attention to looping in the game as I wasn’t aware of the issue at the time when I was using 3D panner instead of Oculus Spatializer).

Is it a bug or am I doing something wrong (I doubt that since I followed FMOD’s official tutorial) ?

Thanks beforehand

  • You must to post comments
Best Answer
1
1

Hi Alex,

This is the result of the sounds getting spatialized (or more specifically attenuated) twice. The scatter applies 3D panning and attenuation, then the spatializer plugin applies additional attenuation on top of that – so it gets attenuated twice and gets very quiet or silent.

There are two options here, depending on whether you want to scatter the sounds or just trigger them randomly.

If you want to scatter using the spatializer you need to use events instead of sound files. Put a sound you want to scatter into it’s own event, then replace the 3D panner with Oculus spatializer. Then put this event inside your scatterer sound playlist. Note: make sure there is no spatializer or 3D panner on the parent event that holds the scatterer sound. Note2: this will spawn many instances of the spatializer which has a greater performance hit than 3D panning, this could be an issue if there are many sounds playing at once.

Alternatively you can use the scatterer to randomly trigger sounds but all of them coming from a single point in space. To do this set the “Min & Max Scatter Distance” to 0.00 – 0.00 that will prevent the attenuation from the FMOD 3D panner and send a full scale signal through the the spatializer. In this case you should have a spatializer on the parent event that holds the scatterer sound.

-Pete

  • Alex Zubov

    Thanks Pete!

    I needed alternative variant and setting Min/Max scatter distance to 0 – 0 on the scatterer did the trick :)

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.