Answered
0
0

Hello guys, it my first time with FMOD so i tried to do a simple thing (emitting a sound that my sound engineer gave me as a bank) but it doesn’t work.

What I’ve done so far:
1. Imported FMOD and banks correctly (I can see FMOD inside my project and if I click on Event Browser I can see the list of my sounds created in FMOD Studio and I can hear them if I press play).
2. Inside my main camera I’ve attached FMOD Audio Listener.
3. I created a gameobject named Planes with Studio Event Emitter Script attached. In the event variable inside the script I selected a bank called Planes_LOOP using the search button and I tried to select, inside the Start variable, Object start and Object Enabled, but when I start the game, the sound is not working.

Do you know what i’m doing wrong?

Thank you in advance

  • You must to post comments
Best Answer
1
0

2D or 3D sound?

If 3D sound it could be that your listener position is not near enough to the emitter.

You can use Override Attenuation in the FMOD Emitter Component in Unity to increase the radius for the sound.

Cheers

  • Matteo Muratore

    thank you for the override attenuation! You were right, even if the audio listener was really close, it wasn’t SO close! thank you again!

  • You must to post comments
0
0

It looks as though you may be setting the stop event of the emitter.
Make sure only the Play Event is set to Object Start or Enabled.

  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.