Answered
0
0

Hello

Our audio designer has an fmod event setup such that we have a single event that holds several short different animal sounds. The animal sound we want triggered is controlled by the parameter “Animal”.

So when I trigger the Fmod event, i do these steps:

  • create fmod instance
  • set the parameter “Animal” to the desired animal
  • Start() instance

i’ve also tried:

  • create fmod instance
  • Start() instance
  • set the parameter “Animal” to the desired animal

This doesn’t seem to work. Rather than hearing the individual animal sound that we want, it seems to be playing a mashup of random sounds rather than the exact one we want. We also tried to set the “Animal” parameter to 0.0 (in code) and it would still play random sounds…

Note that we have no problems controlling other sounds with special parameters, we have been using fmod studio for over a year without any problem. But this is a special case where we want to trigger only a single short sound with a parameter and it is not working!

I am using Fmod studio 1.06 in Windows 8.1

enter image description here

  • You must to post comments
Best Answer
0
0

Hello Geoff,

Thanks for helping out. I needed to call start() after setting the parameter. now it works perfect.

Thank you very much

Best,
Eddie

  • You must to post comments
0
0

Setting the parameter before calling start() should work fine. Can you verify that you haven’t accidentally applied a seek speed on the animal parameter – you can check it by clicking the animal parameter tab twice and seeing the seek speed dial. Seek speed would cause the parameter to gradually climb through all the sounds, causing what you describe.

Another thing you can do is connect the profiler and examine the parameter value to make sure it is what you expect.

If you still don’t have any luck and think you have found a bug, you can contact support@fmod.com and we can see about getting a profiler replay to see what is going on.

  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.