0
0

I’ve been working on a project for a while now – suddenly today I got a build error message and afterwards I’m not getting any audio in editor window play mode, yet I can click on the events in the content browser and hear all of them perfectly well.

I have rebuilt in FMOD and UE has recognized and reloaded the banks yet still nothing?

I’m running UE4.14 and FMOD studio 1.09.01 with the 4.14 / 1.09.01 for 4.14 plugin.

Any help would be appreciated!

Thanks.

  • Cameron Baron

    What was the build error message?

  • Martyn Stonehouse

    It was a ‘build string’ error ?

  • Cameron Baron

    I am not sure what that could mean, do you have a screenshot or anymore information about the error?

  • Martyn Stonehouse

    just posted a couple of project screenshots…

  • You must to post comments
0
0

UE project settings – https://www.dropbox.com/s/xp3svn46pyptal7/fmodparta.PNG?dl=0

FMOD project settings – https://www.dropbox.com/s/fgl05k6i4xyfn01/fmodpartb.PNG?dl=0

These are both the same build folder – when I build in FMOD I see unreal picked it up and ‘reloads the banks’ automatically – but still no audio? I can play fmod events in the UE content browser but they won’t play in-game.

Thanks for your help Cameron!

  • Cameron Baron

    Those pictures don’t tell me anything about the error. Unreal Engine will print out a log file, as well as showing the error in editor, without seeing that we would just be guessing.

  • Martyn Stonehouse

    Hi Cameron – thanks for getting back to me again. I’m afraid the error only occured the one time and I can’t seem to replicate it – as far as I can tell there is no reason why the project will not produce audio in game mode. I have other projects all working fine, and starting a fresh project also works no problem. I’m afraid I don’t have the log from the original error. Running an ‘FMOD validation’ from inside UE says everything is correct, as does the project validation in FMOD itself. I can connect to the project live but FMOD receives no event triggers from UE when checking in the profiler, just sits idle.

  • Cameron Baron

    The only thing I can think of that may cause it is if you are using a plugin in Studio that you haven’t added to the plugins list in settings.

  • Martyn Stonehouse

    Hi Cameron – I’ve managed to get this from the output log – seems to be whats causing the problem!

    https://www.dropbox.com/s/b6n7kplcch46z7z/UE%20Output%20Log.PNG?dl=0

  • Cameron Baron

    You will get those warnings on startup, which is unavoidable at the moment, but you shouldn’t get them again after that. If you are then it could mean there is an issue.

  • You must to post comments
0
0

Hey, a similar thing happened to me this week and what I found was that a setting in Unreal’s editor preferences called ‘Enable Sound’ in Level Editor – Play section got unchecked. Checking the box off again allowed me to hear my dialogue when I would play in the editor. Try that!

  • Martyn Stonehouse

    Hi Scott! Thanks for posting – I’ve already tried that I’m afraid and no joy..!

  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.