Answered
0
0

Hi there. I’m having a bit of a problem. Having to load a bunch of audio files into memory can be very expensive if they’re large files. This is avoidable by using createStream() as opposed to createSound()

However, it seems that regardless of whether I initialize FMOD with a bunch of channels, I seem to be limited to about 32 (it’s around there anyway) streams, or rather, I cannot create a stream after 32 FMOD sounds are playing.

Is there anyway around this limit somehow?

The sound system is initialized like so:

error = m_pSoundSystem->init(FMOD_MAXCHANNELS, FMOD_INIT_NORMAL, 0);

FMOD_MAXCHANNELS is defined as 256.

Is there a flag or something that allows the initialization of more streams? This is a really annoying problem.

  • You must to post comments
Best Answer
0
0

You should probably look at System::setSoftwareChannels. There are no stream limits, just software mixed voices. The streams are playing, just not audible (they are virtual).

  • Michael Barth

    Hm, I tried setting the software channels, but nothing happened. Is there something I should do in conjunction with setting the software channels?

  • Michael Barth

    OH! I figured it out, you’re supposed to set it before calling the system’s init function. It worked. Thank you!

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.