invoking fmod designer with the -b command does not seem to work at all.

Giving it a file which exists does nothing.

Giving it a file that doesnt exist does nothing.

The exit code is always 1.

Some sort of error message at least would be helpful in case I am messing something up.

  • You must to post comments

yes i did.

an example:

./fmod_designer.exe -b -pc invalid_filename

says nothing. no file not found.

./fmod_designer -invalid_option

says nothing. no invalid option.

./fmod_designer.exe -b -pc valid_file.fdp

says nothing. does nothing.

./fmod_designer.exe valid_file.fdp

works as expected (loads the gui with the valid file loaded)


  • You must to post comments

Command line support is pretty rudimentary at the moment. It does work but only if you run fmod_designer.exe from the directory that the .fdp is in. You can verify this by building the example project like so :

cd "\Program Files\FMOD SoundSystem\FMOD Designer\examples"
..\fmod_designer.exe -b -pc examples.fdp

I’ll at least get this documented for now but rest assured it will be fixed soon.


  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.