like the others reporting in this forum, I’ve suffered the error (crash) when calling FMOD::System::release().

It always failed at the same location. With your latest dev build, I’ve been able to trace with more details the location of the problem (thanks to your debug libs):


function FMOD::OutputDSounds::update

in this function, there are a number of calls to (in order):

  • FMOD::SystemI::get3DNumListeners
  • FMOD::SystemI::get3DListenerAttributes
  • FMOD::SystemI::get3DSettings

then a series of tests on variables rooloffscale, distancescale, dopplerscale

then erase the struct dsListenerParams

then a call to a function (virtual function?) that leads to an error message if failed:

"IDirectSoundListener::SetAllParameters returned errcode %08X"

then call FMOD::ChannelPool::getNumChannels
then call FMOD::ChannelPool::getChannel (in a loop)


right after the loop that call getChannel above, there is a call to a function (in the debugger, this+0x244 seems to be a pointer to a class, which seems to have a vTbl and the function calls this vTbl+0x44). The vTbl seems to be pointing to 0! maybe an error (a class without a virtual destructor somewhere)??

So the code fails at this exact location everytime!

with fmodexD.dll, this is happening at 006C8F97 (DLL base listed at 006C0000 in the debugger).

Hope this helps!


  • You must to post comments

I’ve been getting problems when calling release recently too (technically through EventSystem::release, but that calls system::release anyway IIRC). I can get it to crash fairly often with a specific sequence of actions in my code (not really possible to extract an example to send though I’m afraid), although if I do a Sleep(someSmallTime) or such like before the release, it doesn’t crash.

Of course the sleep could be hiding any number of sins, but is it necessary to have a delay between stopping and unloading sounds/events and calling release?

  • You must to post comments


the error is still at the same location, but I have a couple more info to trace! Here is a dump of the debugger. The error is at 00708F8A with the mov eax, dword ptr [esi] with esi in this session beeing 0x02C97640.

00708F39 call FMOD::ChannelPool::getNumChannels (757CEBh)
00708F3E cmp eax,ebx
00708F40 je FMOD::OutputDSound::update+200h (708F47h)
00708F42 jmp FMOD::OutputDSound::update+278h (708FBFh)
00708F44 mov dword ptr [numchannels],ebx
00708F47 xor edi,edi
00708F49 cmp dword ptr [numchannels],ebx
00708F4C jle FMOD::OutputDSound::update+23Ch (708F83h)
00708F4E mov ecx,dword ptr [esi+3Ch]
00708F51 lea eax,[channelreal]
00708F54 push eax
00708F55 push edi
00708F56 call FMOD::ChannelPool::getChannel (757D5Ch)
00708F5B cmp eax,ebx
00708F5D jne FMOD::OutputDSound::update+278h (708FBFh)
00708F5F mov ecx,dword ptr [channelreal]
00708F62 cmp ecx,ebx
00708F64 je FMOD::OutputDSound::update+272h (708FB9h)
00708F66 cmp dword ptr [numlisteners],1
00708F6A jg FMOD::OutputDSound::update+22Dh (708F74h)
00708F6C test word ptr [ecx+46h],420h
00708F72 je FMOD::OutputDSound::update+236h (708F7Dh)
00708F74 mov eax,dword ptr [ecx]
00708F76 call dword ptr [eax+60h]
00708F79 cmp eax,ebx
00708F7B jne FMOD::OutputDSound::update+278h (708FBFh)
00708F7D inc edi
00708F7E cmp edi,dword ptr [numchannels]
00708F81 jl FMOD::OutputDSound::update+207h (708F4Eh)
00708F83 mov esi,dword ptr [esi+244h]
00708F89 push esi
00708F8A mov eax,dword ptr [esi]
00708F8C call dword ptr [eax+44h]
00708F8F test eax,eax
00708F91 je FMOD::OutputDSound::update+276h (708FBDh)
00708F93 push dword ptr [hr]
00708F96 push offset string "IDirectSoundListener::CommitDefe"... (790ED0h)
00708F9B push offset string "OutputDSound::update" (790F14h)
00708FA0 push 5CDh
00708FA5 push offset string "c:\pc\src\sound\fmod4\win32\src\"... (790B88h)
00708FAA push 1
00708FAC call FMOD::Debug (70ED5Eh)

In short, it is in your outputDSound::Update, there is a call to get the number of channels, and then a loop to check each channel and if the channel is "real", then it must do something prior calling IDirectsoundListener::CommitDeferedSettings().

Also interesting, the debuger locals show a "this" points of type FMOD::OutputDSound * const with a value of 0x3F800000 which in fact does not look to be a pointer (it is 1.0f float in IEEE hexa).

Another debugger hint makes me think the issue is with the class "channelreal" wich is has virtual functions, and with a __frptr which cannot be evaluated (so my hinch in my previous post could proove to be the reason of what is happening).

NB: I’m not using 3D sound, just normal sound.

Hope this helps! this is so very well located in the code that I see no reason we can’t solve it once for all!

And the call stack to go to this error is:

FMOD::SystemI::release() Line 3470
FMOD::SystemI::close() Line 5086
FMOD::SystemI::closeEx(unsigned char calledfrominit = 0x00) line 5142
FMOD::SystemI::update() Line 5480
FMOD::OutputDSound::updateCallback(FMOD_OUTPUT_STATE* output=0x003586b0) Line 2441
FMOD::OutputDSound::update() Line 1483 + 0x7 bytes

Hope this helps!

  • You must to post comments

I’m using 4.03.30.

That is an extremely old version so unfortunately that doesnt help at all, it could be any manner of things that were fixed. The current version is 4.04.35

  • You must to post comments

are you using non blocking loading at all, if so we just fixed a timing related issue there in v33

  • You must to post comments

If you are certain that you are using only 2D sounds (FMOD_2D) then are you using more than one listener?

  • You must to post comments

[quote:3vdwupa1]That is an extremely old version so unfortunately that doesnt help at all, it could be any manner of things that were fixed. The current version is 4.04.35[/quote:3vdwupa1]

Sorry… that was a typo… I’m indeed using the current "4.04.30 stable" release.

  • You must to post comments

Yes, I am using non-blocking loading. I’ll update to v33 and check

  • You must to post comments

I’m a bit suspicious of cptlucky’s crash because if it was as simple as System::release everyone would get it, and noone else is getting it, so i really need the steps to reproduce that, and for you to make sure its not something in your code corrupting fmod.

If fmod has a pointer of 0x3f800000 then it is possible a corruption from some other place has stomped on it with float data.

The last crash with crouton and a few others was a specific case of fsb files being opened as streams and timing. This is not specific to anything it is just a matter of releasing the system object which everyone is doing.

If it is reproducible then can’t you just start disabling stuff in your code until it goes away until you find the culprit?

  • You must to post comments

thats still a different branch to what we’re talking about, could you try with the development branch

  • You must to post comments

Well, I’ve just checked with v33 and it is still happening. NB: I’m not using NON BLOCKING API at all. I’ve tried the tip in this thread in adding a Sleep(1000) before the call to system->release() and this does not change anything.

It is hard to tell what particular sequence of action when opening the API could lead to this, however, the directions I’ve given to locate the code trying to get a value from memory from a pointer to this memory that is null should be easy to catch? It is always crashing at the same code location…

Hope this helps!

  • You must to post comments

Hi Bret, I’m sure it is something simple. Maybe a set of parameters goes wild in the lib? Neverheless, I’ve removed any call to create sound / create channel, so the application just init the sound library with the code pasted below, and closes it when leaving the application, with a call to update between the two in a thread that just does that: calling FMOD:update()


    FMOD_RESULT result;

    // create the main system

    result = FMOD::System_Create(&SoundSystem);     // Create the main system object.
    if (result != FMOD_OK)
        throw (result);

    // need 32 channels minimum

    result = SoundSystem->setSoftwareChannels(32);
    if (result != FMOD_OK)
        throw (result);

    // setup the software mixer format

    result = SoundSystem->setSoftwareFormat(48000,FMOD_SOUND_FORMAT_PCM16,2,2,FMOD_DSP_RESAMPLER_LINEAR);
    if (result != FMOD_OK)
        throw (result);

    // setup the output speakers with the control panel speaker modes

    int numdrivers;
    result = SoundSystem->getNumDrivers(&numdrivers);
    if (result != FMOD_OK)
        throw (result);
    if (numdrivers == 0)
        throw ("No Sound Card detected on the system");

    // assume primary output driver is always at index 0

    FMOD_CAPS           caps;
    FMOD_SPEAKERMODE    speakermode;
    result = SoundSystem->getDriverCaps(0,&caps,0,0,&speakermode);
    if (result != FMOD_OK)
        throw (result);

    result = SoundSystem->setSpeakerMode(speakermode);
    if (result != FMOD_OK)
        throw (result);

    // ready to start the system

    result = SoundSystem->init(100, FMOD_INIT_NORMAL, 0);    // Initialize FMOD.
    if (result != FMOD_OK)
        throw (result);

    // Create sound Groups

    result = SoundSystem->getMasterChannelGroup( &SoundGroups[Group_Master]);
    if (result != FMOD_OK)
        throw (result);


And here is below the log file:

FMOD: OutputDSound::registerDLL : Detected DIRECTX 9
FMOD: FMOD_Output_DSound_EnumProc : Enumerating "Primary Sound Driver"
FMOD: FMOD_Output_DSound_EnumProc : Enumerating "SoundMAX HD Audio"
FMOD: FMOD_Output_DSound_EnumProc : Enumerating "Bluetooth Audio"
FMOD: FMOD_Output_DSound_EnumProc : Enumerating "Bluetooth High Quality Audio"
FMOD: OutputDSound::getDriverCaps : Register DLL
FMOD: OutputDSound::getDriverCaps : Enumerate Drivers
FMOD: OutputDSound::getDriverCaps : CoInitialize
FMOD: OutputDSound::getDriverCaps : DirectSoundCreate8 : id = 0
FMOD: OutputDSound::getDriverCaps : GetCaps
FMOD: OutputDSound::init : Bad Caps or emulated driver. Reverting back to software
FMOD: OutputDSound::close :
FMOD: OutputDSound::close : Free channel pool 2d
FMOD: OutputDSound::close : Free channel pool 3d
FMOD: OutputDSound::close : Release directsound listener
FMOD: OutputDSound::close : Release directsound object
FMOD: OutputDSound::close : FreeLibrary on dsound3d.dll
FMOD: OutputDSound::close : FreeLibrary on dsound.dll
FMOD: OutputDSound::close : Free driver list
FMOD: OutputDSound::close : done
FMOD: SystemI::init : maxchannels = 100, flags = 00000000, extradriverdata = 00000000
FMOD: SystemI::close :
FMOD: SystemI::close : Shut down streamer and FMOD_NONBLOCKING and FileSystem thread.
FMOD: SystemI::close : Remove all user channel groups.
FMOD: SystemI::close : Remove ‘main’ channel group.
FMOD: SystemI::close : Remove miscllaneous DSP stuff.
FMOD: SystemI::close : done.

FMOD: OutputDSound::init : Register DLL
FMOD: OutputDSound::init : Enumerate Drivers
FMOD: FMOD_Output_DSound_EnumProc : Enumerating "Primary Sound Driver"
FMOD: FMOD_Output_DSound_EnumProc : Enumerating "SoundMAX HD Audio"
FMOD: FMOD_Output_DSound_EnumProc : Enumerating "Bluetooth Audio"
FMOD: FMOD_Output_DSound_EnumProc : Enumerating "Bluetooth High Quality Audio"
FMOD: OutputDSound::init : DirectSoundCreate8 : mSelectedDriver = -1
FMOD: OutputDSound::init : SetCooperativeLevel
FMOD: OutputDSound::init : GetCaps
FMOD: OutputDSound::init : Bad Caps or emulated driver. Reverting back to software
FMOD: OutputDSound::init : Create Primary Buffer
FMOD: OutputDSound::init : Set Primary Buffer Format
FMOD: OutputDSound::init : Getting Listener Interface
FMOD: OutputDSound::init : Done
FMOD: SystemI::init : Set up software engine
FMOD: OutputDSound::createSample : length 4096, channels 2, format 2, mode 0000002a
FMOD: OutputDSound::createSample : done
FMOD: Thread::initThread : Initializing FMOD mixer thread. priority 3
FMOD: Thread::initThread : – Stacksize 32768. Stack pointer 00000000 : usesemaphore = 0 : sleeptime = 10
FMOD: Thread::initThread : done.
FMOD: Thread::callback : * FMOD mixer thread started
FMOD: SystemI::init : Set up emulated output
FMOD: SystemI::init : create the channel pool
FMOD: SystemI::init : Set up streamer
FMOD: Thread::initThread : Initializing FMOD stream thread. priority 2
FMOD: Thread::initThread : – Stacksize 32768. Stack pointer 00000000 : usesemaphore = 0 : sleeptime = 10
FMOD: Thread::callback : * FMOD stream thread started
FMOD: Thread::initThread : done.
FMOD: SystemI::init : done

FMOD: SystemI::close :
FMOD: SystemI::recordStop :
FMOD: SystemI::recordStop : done
FMOD: SystemI::close : Stop all sounds

  • You must to post comments

Hi Bret,

it is unfortunate we don’t have new report from Billp who’s experiencing the same issue. It turns out after experimenting for a month with this that the root of the issue is this: when FMOD is used (init/loop/release) from a DLL code, which DLL is used by an application .exe, then, it exhibit this crashing issue.

Now this begs the question to you: What is the correct way to use the fmod sound system from a DLL, that is itself used by a .exe, or by another DLL?

Do you have a typical code fragement of how and where to place the init, the loop, and the release code blocks?

This is critical it is used from a DLL.

Thanks in advance.


  • You must to post comments

My problem may be different from CptLucky’s of course, but I’m still getting the same problem with v35 i.e. crashes if I don’t do the sleep before calling release. It seems to be only when I’ve triggered music for my jukebox that does it though, and they come from Stream From Disk wave banks (can have a maximum of 2 loaded at any time, but only 1 playing).

When I used the debug output the last time to see if that helped, the last entries just say

FMOD: SystemI::close : Free software output.
FMOD: SystemI::close : Free emulated output.
FMOD: SystemI::close : Free channel pool.
FMOD: SystemI::close : Remove miscllaneous DSP stuff.
FMOD: SystemI::close : done.

FMOD: EventSystemI::release : released.

So no real help there (for me anyway).

  • You must to post comments

I’ve futher made a test: I’ve disabled any call to FMOD::update. The application now crashes in another code point when calling ->release(). The call stack is the same as the other message I’ve posted above (well, on page 1 of the thread). It now crashes a little earlier but always in the same function of your code. Here is the disassembly, the EIP is stopped at 0x00708EF1 mov ecx, dword ptr [eax] with eax = 0x02C97640 (which ressemble a memory allocated in the heap).

0708D2D mov eax,dword ptr [esp+4]
00708D31 test eax,eax
00708D33 jne FMOD::OutputDSound::getHandle+0Dh (708D3Ah)
00708D35 push 24h
00708D37 pop eax
00708D38 jmp FMOD::OutputDSound::getHandle+17h (708D44h)
00708D3A mov ecx,dword ptr [ecx+240h]
00708D40 mov dword ptr [eax],ecx
00708D42 xor eax,eax
00708D44 ret 4
00708D47 push ebp
00708D48 mov ebp,esp
00708D4A sub esp,8Ch
00708D50 fldz
00708D52 push ebx
00708D53 push esi
00708D54 fstp dword ptr [ebp-44h]
00708D57 fldz
00708D59 mov esi,ecx
00708D5B xor ebx,ebx
00708D5D fstp dword ptr [ebp-40h]
00708D60 fldz
00708D62 cmp dword ptr [esi+244h],ebx
00708D68 push edi
00708D69 fstp dword ptr [ebp-3Ch]
00708D6C fldz
00708D6E fstp dword ptr [vel]
00708D71 fldz
00708D73 fstp dword ptr [ebp-34h]
00708D76 fldz
00708D78 fstp dword ptr [ebp-30h]
00708D7B fldz
00708D7D fstp dword ptr [front]
00708D80 fldz
00708D82 fstp dword ptr [ebp-1Ch]
00708D85 fld1
00708D87 fstp dword ptr [ebp-18h]
00708D8A fldz
00708D8C fstp dword ptr [top]
00708D8F fld1
00708D91 fstp dword ptr [ebp-28h]
00708D94 fldz
00708D96 fstp dword ptr [ebp-24h]
00708D99 je FMOD::OutputDSound::update+276h (708FBDh)
00708D9F mov ecx,dword ptr [esi+34h]
00708DA2 lea eax,[numlisteners]
00708DA5 push eax
00708DA6 call FMOD::SystemI::get3DNumListeners (766C89h)
00708DAB cmp eax,ebx
00708DAD jne FMOD::OutputDSound::update+278h (708FBFh)
00708DB3 cmp dword ptr [numlisteners],1
00708DB7 jne FMOD::OutputDSound::update+93h (708DDAh)
00708DB9 lea eax,[top]
00708DBC mov ecx,dword ptr [esi+34h]
00708DBF push eax
00708DC0 lea eax,[front]
00708DC3 push eax
00708DC4 lea eax,[vel]
00708DC7 push eax
00708DC8 lea eax,[pos]
00708DCB push eax
00708DCC push ebx
00708DCD call FMOD::SystemI::get3DListenerAttributes (766F05h)
00708DD2 cmp eax,ebx
00708DD4 jne FMOD::OutputDSound::update+278h (708FBFh)
00708DDA lea eax,[rolloffscale]
00708DDD mov ecx,dword ptr [esi+34h]
00708DE0 push eax
00708DE1 lea eax,[distancescale]
00708DE4 push eax
00708DE5 lea eax,[dopplerscale]
00708DE8 push eax
00708DE9 call FMOD::SystemI::get3DSettings (766C36h)
00708DEE cmp eax,ebx
00708DF0 jne FMOD::OutputDSound::update+278h (708FBFh)
00708DF6 fld dword ptr [dopplerscale]
00708DF9 fcomp dword ptr [esi+27Ch]
00708DFF fnstsw ax
00708E01 test ah,44h
00708E04 jp FMOD::OutputDSound::update+0F6h (708E3Dh)
00708E06 fld dword ptr [distancescale]
00708E09 fcomp dword ptr [esi+280h]
00708E0F fnstsw ax
00708E11 test ah,44h
00708E14 jp FMOD::OutputDSound::update+0F6h (708E3Dh)
00708E16 fld dword ptr [rolloffscale]
00708E19 fcomp dword ptr [esi+284h]
00708E1F fnstsw ax
00708E21 test ah,44h
00708E24 jp FMOD::OutputDSound::update+0F6h (708E3Dh)
00708E26 mov eax,dword ptr [esi+34h]
00708E29 cmp byte ptr [eax+9E8h],bl
00708E2F jne FMOD::OutputDSound::update+0F6h (708E3Dh)
00708E31 cmp byte ptr [eax+9E9h],bl
00708E37 je FMOD::OutputDSound::update+23Ch (708F83h)
00708E3D push 40h
00708E3F lea eax,[dsListenerParams]
00708E45 pop edi
00708E46 push edi
00708E47 push ebx
00708E48 push eax
00708E49 call memset (782A5Ch)
00708E4E mov eax,dword ptr [dopplerscale]
00708E51 add esp,0Ch
00708E54 fld1
00708E56 mov dword ptr [ebp-50h],eax
00708E59 mov eax,dword ptr [rolloffscale]
00708E5C fdiv dword ptr [distancescale]
00708E5F mov dword ptr [ebp-54h],eax
00708E62 mov eax,dword ptr [front]
00708E65 mov dword ptr [ebp-70h],eax
00708E68 mov eax,dword ptr [ebp-1Ch]
00708E6B mov dword ptr [ebp-6Ch],eax
00708E6E mov eax,dword ptr [ebp-18h]
00708E71 mov dword ptr [ebp-68h],eax
00708E74 mov eax,dword ptr [top]
00708E77 mov dword ptr [ebp-64h],eax
00708E7A mov eax,dword ptr [ebp-28h]
00708E7D mov dword ptr [ebp-60h],eax
00708E80 mov eax,dword ptr [ebp-24h]
00708E83 mov dword ptr [ebp-5Ch],eax
00708E86 mov eax,dword ptr [pos]
00708E89 mov dword ptr [ebp-88h],eax
00708E8F mov eax,dword ptr [ebp-40h]
00708E92 mov dword ptr [ebp-84h],eax
00708E98 mov eax,dword ptr [ebp-3Ch]
00708E9B mov dword ptr [ebp-80h],eax
00708E9E mov eax,dword ptr [vel]
00708EA1 mov dword ptr [ebp-7Ch],eax
00708EA4 mov eax,dword ptr [ebp-34h]
00708EA7 mov dword ptr [ebp-78h],eax
00708EAA mov eax,dword ptr [ebp-30h]
00708EAD mov dword ptr [ebp-74h],eax
00708EB0 mov eax,dword ptr [esi+34h]
00708EB3 mov dword ptr [dsListenerParams],edi
00708EB9 fstp dword ptr [ebp-58h]
00708EBC test byte ptr [eax+1Ch],2
00708EC0 je FMOD::OutputDSound::update+19Bh (708EE2h)
00708EC2 fld dword ptr [ebp-18h]
00708EC5 fchs
00708EC7 fstp dword ptr [ebp-68h]
00708ECA fld dword ptr [ebp-24h]
00708ECD fchs
00708ECF fstp dword ptr [ebp-5Ch]
00708ED2 fld dword ptr [ebp-3Ch]
00708ED5 fchs
00708ED7 fstp dword ptr [ebp-80h]
00708EDA fld dword ptr [ebp-30h]
00708EDD fchs
00708EDF fstp dword ptr [ebp-74h]
00708EE2 mov eax,dword ptr [esi+244h]
00708EE8 lea edx,[dsListenerParams]
00708EEE push 1
00708EF0 push edx
00708EF1 mov ecx,dword ptr [eax] ***** <—- CRASHES HERE *****
00708EF3 push eax
00708EF4 call dword ptr [ecx+28h]
00708EF7 cmp eax,ebx
00708EF9 mov dword ptr [hr],eax
00708EFC je FMOD::OutputDSound::update+1CCh (708F13h)
00708EFE push eax
00708EFF push offset string "IDirectSoundListener::SetAllPara"... (790F2Ch)
00708F04 push offset string "OutputDSound::update" (790F14h)
00708F09 push 592h
00708F0E jmp FMOD::OutputDSound::update+25Eh (708FA5h)

  • You must to post comments

[quote:yoyquus8]it is unfortunate we don’t have new report from Billp who’s experiencing the same issue[/quote:yoyquus8]

Apologies… I tried to update to a newer version, it didn’t "just work" so there was a delay, which was just enough time for a "high priority interrupt" to drag me to another project 😡

Side note for one second… The "didn’t just work" was that Eventsystem::getGroup returns an "Invalid Parameter" with the newer versions, and it used to just work. Now that I’m back into this, I found that EventSystem::load has changed and has a 3rd argument, the EventProject pointer.

If I use Event[b:yoyquus8]Project[/b:yoyquus8]::getGroup, my code is back to operational.

OK, let me first admit that I haven’t looked through the forum for an answer, but let me just ask: Does EventProject now [i:yoyquus8]supercede [/i:yoyquus8] EventSystem::getGroup()? Or should BOTH still work?

I am now using 4.04.51

Back to the DLL issue…
[quote:yoyquus8]It turns out after experimenting for a month with this that the root of the issue is this: when FMOD is used (init/loop/release) from a DLL code, which DLL is used by an application .exe, then, it exhibit this crashing issue. [/quote:yoyquus8]

I am just now back to getting my code working under 4.04.51, but I noted that the very first run of this code as a DLL failed in the same place… Sound::release().

I am using VC++ Express, FWIW. The non-DLL version of the code runs fine (basically my previous report, all over again), and the DLL version runs FINE, but just is not happy with release().

I will experiment some more and report any findings.



  • You must to post comments

does anyone have a simple project that reproduces this issue? When we do this with our tests there are no crashes, so there is something you guys are doing different to us, though i’m trying everything.

edit: i may have reproduced it i’ll keep you posted.

  • You must to post comments

Additional report:

now if I call again FMOD::update(), it still crash of course, but back at the same location as initialy posted, right before the call to direct sound CommitDeferredSettings

I’ve forgotten to add: the windows message I get is:

Unhandled exception at 0x00708f8a (fmodex.dll) in myapplication.exe: 0xC0000005: Access violation reading location 0x02b37640.

I’ve no doubt all is fine for everyone, but it seems I’ve found a code path for at least any FMOD DLL for the past 2 months to lead to a crash ALWAYS at the SAME LOCATION, right before the call to CommitDeferredSettings.

I hope all this information will help you track it down. It seems I use pretty much standard init code?!?

Hope this helps!

  • You must to post comments

On your side note, with the addition of EventProject, EventSystem::getGroup paths now need to include their EventProject name as well e.g.




Same goes for EventSystem::getEventGroup.

  • You must to post comments

Ok i have reproduced a release crash especially to do with streams, and put a new intermediate version at ftp://ftp.fmod.org l:upload p:upload in the development directory.

It is 4.04.37, let me know how you go with it.

  • You must to post comments


our error reportting system shows a crash like this, too. I haven’t been able to locate where fmod crashes in these situations and we are not able to reproduce it on our developing and testing machines as well. It’s just some sheldom effect that occours on systems of our users. The only thing I know is that we got no such reports from Linux and Mac users only on Windows.


  • You must to post comments
Showing 1 - 20 of 30 results
Your Answer

Please first to submit.