Whenever my application tries to call Factory.System_Create(), I get the following error when I run the app in Visual Studio:
[code:vo05bxfg]Unable to load DLL ‘fmodex.dll’: The specified module could not be found.[/code:vo05bxfg]
.. or this when I just run the .exe:
[code:vo05bxfg]An attempt was made to load a program with an incorrect format.[/code:vo05bxfg]

I have placed the DLL file in the following directories in my project’s path, and tried to run them as both "Debug" and "Release" in VS and just run the exe, with no luck:

[b:vo05bxfg]MessageBox.Show("test1")[/b:vo05bxfg] is executed, but [b:vo05bxfg]MessageBox.Show("test2")[/b:vo05bxfg] isn’t.

[code:vo05bxfg]using System;
using System.Collections.Generic;
using System.ComponentModel;
using System.Data;
using System.Drawing;
using System.Text;
using System.Windows.Forms;
using FMOD;

namespace WindowsApplication1
public partial class Form1 : Form
public Form1()

    private void button1_Click(object sender, EventArgs e)
        FMOD.System pFMod_System = null;
        Factory.System_Create(ref pFMod_System);


What’s going on?

  • You must to post comments

I just now sent the app to a friend of mine running Windows XP 32 bit.. And it worked for him..
I’m running Vista 64 bit and it doesn’t work for me.. Hmm..

Edit: I tried the 64 bit version of FMOD Ex.. and it worked for me.. Yay. 😀

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.