0
0

[b:2it7ctqj]Detailed description:[/b:2it7ctqj]
In some cases, audio sent to the rear channels, either automatically though 3D spatialisation or manually by setSpeakerMix, may come out of the front channels when using a Sound Blaster sound card.

[b:2it7ctqj]Solution 1:[/b:2it7ctqj]
1. Try FMOD_SOFTWARE.
FMOD_SOFTWARE disables hardware accelleration in favour of the FMOD CPU-based software mixer, overriding the default FMOD_HARDWARE, which does not support 2D multi-speaker sound and may prevent switching between 2D and 3D sound.
Note that this solution is specific to FMOD_HARDWARE with the Direct Sound output mode, which is no longer supported in branches after 4.30.

[b:2it7ctqj]Solution 2:[/b:2it7ctqj]
1. Open the Creative ‘Audio Control Panel.’
2. Disable all the effects.
3. Set the speaker configuration to 5.1.
In some cases, the Audio Control Panel may have settings different to those set in the operating system’s equivilent. If the Audio Control panel is set up to output to headphones, for example, the Operating System’s speaker configuration will be effectively overridden.

[b:2it7ctqj]Solution 3:[/b:2it7ctqj]
1. Ensure you are running the latest sound card drivers.

[b:2it7ctqj]Notes:[/b:2it7ctqj]
The ‘FMOD_MODE’ and ‘3D SOUND’ sections of the prorammer’s API documentation contain more information about this issue.

  • You must to post comments
Showing 0 results
Your Answer

Please first to submit.