[b:oxer58q3]Detailed description:[/b:oxer58q3]
Under certian circumstances, the apparent pitch of an audio file may appear to have been lowered. In many cases, this is because FMOD automatically stretches sounds to align with a 1152 sample mpeg boundary, in order to facilitate seamless looping.

[b:oxer58q3]Solution 1:[/b:oxer58q3]
1. Crop the file’s length to a multiple of 1152 samples.
With a precise multiple, no stretching will be required, and the sound will loop seamlessly.

[b:oxer58q3]Solution 2:[/b:oxer58q3]
1. In Fsbankex.exe, uncheck the ‘loop on/off’ checkbox for the sound file in question.
This will pad the file to the next 1152 sample boundary with silence. This will prevent looping from being seamless, but will not cause the file to be stretched.

More information on this topic can be found under ‘COMPRESSION QUALITY, MULTICHANNEL AND LOOPING WITH LOSSY AUDIO FORMATS’ in the FMOD Programmer’s API Documentation.

  • You must to post comments
Showing 0 results
Your Answer

Please first to submit.