0
0

Newbie question: How do I get 2 music samples to start simultaneously? I’ve tried 3 ways, none of which works:

1) In the Events view define an event with 2 layers and 1 sample in each layer. This works for starting simultaneously. However, since I can’t specify tempo and meter, the samples get out of sync–even though they were recorded at the same meter and tempo.

2) In the Music view define a single cue with each sample in a separate segment. Define a blank segment as the starting segment and link it to each of the other 2 segments.

3) In the Music view define 3 cues. Define cue with a blank segment as the starting segment. In the other 2 cues define a single segment each with one of the samples and link the starting cue to the each of the other 2 cues.

In 2) and 3) only one of the samples will play.

So what’s the right way? I would prefer the Events view if I could keep the 2 samples in sync since I’d also like to randomly vary the pitch of one of them.

  • You must to post comments
0
0

[quote:gcbilt9v]1) In the Events view define an event with 2 layers and 1 sample in each layer. This works for starting simultaneously. However, since I can’t specify tempo and meter, the samples get out of sync–even though they were recorded at the same meter and tempo.[/quote:gcbilt9v]
If they started at the same time they should stay in sync unless you change the playback speed using the ‘pitch’ property. If you want time-invariant pitch shifting consider using our Pitch Shift DSP (it is quite expensive in terms of CPU).

An alternative way to play two samples perfectly in sync is to use the multichannel streams, check out this great tutorial by Jeff Schmidt: [url=http://www.youtube.com/watch?v=qOyag-LvhxM:gcbilt9v]part 1[/url:gcbilt9v] [url=http://www.youtube.com/watch?v=hNaL6fIWzGc:gcbilt9v]part 2[/url:gcbilt9v]
This is the standard way to make music in the event view. The only issue is you cannot apply a DSP to one sound without applying it to all of them inside Designer. In the programmer API there is the facility to disable DSP effects per channel using DSP::setSpeakerActive. One advantage of doing it this way is even if you do the normal pitch effect it will change the playback speed of both sounds still keeping the both perfectly in sync.

  • You must to post comments
0
0

Thanks. I had already looked at that multichannel tutorial and wondered why he was using multichannel instead of separate files–so now I know.

However, if dsp has that much overhead, it sounds like I should just do the pitch shifting in Cubase and make separate samples. Originally I planned to use one sample for drums, which would not be pitch shifted, and another for music which would. But if I do the pitch shifting in Cubase I’ll just keep the drums and music together, make a sample for each pitch, and randomly play the samples in a cue.

  • You must to post comments
0
0

That sounds like the way to go. It’s always best to bake in your effects offline as much as possible for two reasons: firstly less CPU makes happy programmers, secondly you can use higher quality effects and get better sound quality. :)

  • You must to post comments
0
0

[quote="peter":c1dw9c5m]That sounds like the way to go. It’s always best to bake in your effects offline as much as possible for two reasons: firstly less CPU makes happy programmers, secondly you can use higher quality effects and get better sound quality. :)[/quote:c1dw9c5m]

I created three loops with different pitches. However, I’m only able to get random playback to work well in two scenarios:

Multitrack Event: If I load the loops into a sound def, the only way I’ve found to play them randomly in an event is to use the "Random Loops Using Spawning" procedure as described on p. 220 of the current user manual. However, there is a noticeable gap between loops during playback.

Music Cue (1): I loaded all the loops into a cue, but could not find a way to get the loops to play randomly. So I linked them to each other in a round-robin sequence. Once again there is a noticeable gap between loops during playback.

Music Cue (2): I loaded each loop into a separate cue and linked them in a round-robin sequence. In this scenario, there are no noticeable gaps in the transition between cues.

Simple Event: Playback is not random, but the Successive Loop option works just as well for my purposes and there are no gaps. However, there is no easy access to real time parameters such as volume as there is with multitrack events.

  • You must to post comments
0
0

Did you get an answer to this by any chance? Im trying to do exactly the same thing with tempo matched loops?

  • You must to post comments
Showing 5 results
Your Answer

Please first to submit.