0
0

Hi guys.
This time I’ve got serious problem.
It happens in game editor and game.
Some of events doesn’t play at all. I found that it depends on how many objects (with sound events) are on the map. But problem starts when there are more than… 10 sounds??!!!
Console shows me this type of error:
"An Event failed to be retrieved, most likely due to ‘just fail’ being specified as the max playbacks behavior."
But parameter max playbacks behavior is set to "just fail if quietest"-’cause I heard that it is the best choice.

Is there something like max channels? how to check it, change, or set loading sounds only close to me (hearable)?

I hope you will help me to find a solution, because this situation stopped progress in adding new sounds.
Take care,
James

  • You must to post comments
0
0

thanks.
I will talk to programmers and we’ll try to find out what’s wrong.
thanks, for now:)

  • You must to post comments
0
0

We also had this issue. Basically we had to limit the number of channels being played to around 12 playing at once, otherwise some sounds wouldn’t play at all. We had adjusted everything "steal priority", maxchannels property, etc and the only thing that resolved this was to limit the number of channels playing per event to not total more than 12 channels for ALL events playing at that instance. We are using 4.36.00. We could use the FMOD event player and play all of the sounds at once with no problem, however in "game" they would not all play when the channels got to 12+. Maybe a bug, maybe a simple setting we overlooked, but nonetheless the only work-around was to limit the sum of all channels being played to below 12 at one time.

  • You must to post comments
0
0

The max playbacks behaviour is dependant on the max playbacks property. Both of these are per event properties so you should have up to ‘n’ instances of any given event where n=maxplaybacks. From your description it is not clear if that is consistent with what you are seeing.

Just Fail If Quietest us a good option if you programmer has set up the code correctly. When implemented correctly JFIQ events should behave like virtual events (when you move around the nearest ones play and the farthest ones go silent). Otherwise Steal Oldest or Steal Quietest can be a bit easier to get up and running. Remember there is no ‘best’ option, each have their purposes, otherwise we would remove the rest.

  • You must to post comments
0
0

That is quite unusual. EventPlayer is implemented using only the public API, we don’t do any special tricks behind the scenes. The reason for this is to make it as much like a game as possible so that sounds designers can audition their content in the ‘real world’. This also means it can usually reproduce any issues which are on the FMOD side. It may be worth having your programmer read through the Getting Started documents for the platforms you support as well as the Tutorial section of the fmodex.chm to see if there is anything they overlooked.

  • You must to post comments
0
0

Well. I don’t know if programmer set everything correctly, but I have checked "steal …." options too and there wasn’t any better.

Max playbacks are set properly. I’ve checked also option with one hundred -where objects were only 20-30, and it didn’t helped.

Anyway I am not talking about the same objects. -you know like I’ve got 10 lamps and only 5 make sound – NO

The problem is with many different objects. When I add some of them like- 2 lamps, 1 radio, 4 fans, 1 hoover -then some of them doesn’t play at all or stop playing when I add a few other.

I think that it is combined with "max channels" (cause it should define all of events/objects in game)- and I wrote that someone set it to for example 64 -but I couldn’t find where is that option.

Please help:)
James

  • You must to post comments
0
0

Well we discovered why our particular audio issue was not playing once the amount of channels played reached approx 12+/- channels. One of the four projects we were using had been changed from Banktype: "Decompress into memory" into "Stream from Disk". Stream from disk was not agreeing with our simulator at all. Once we changed the Bank Type to "Decompress into Memory", it worked flawlessly.

  • You must to post comments
0
0

The maxchannels option is a parameter of is part of the EventSystem::init in code, this can be quite large because virtual channels are cheap. Tell your programmer to try something like 1024.

  • You must to post comments
0
0

well. Actually I don’t know if that’s the problem. He set 64 and even if there are less events, there doesn’t play all of them.

Could be any other reason of that behavior?

  • You must to post comments
0
0

Possibly the maxstreams setting on the soundbank, if it is streaming. You shouldn’t be using streams for most events anyway, compressed sample is the best option in most cases unless it’s music or dialog.

  • You must to post comments
0
0

it also doesn’t solve the problem. Normally I have set 10 streams- but I’ve checked also with 30.

Ok again. I add in world object a, b, c, e, f, g, -then something happens and "a" or "g" completely stops to play.
Any idea?

  • You must to post comments
0
0

Hi James,

Try loading up your project in FMOD Sandbox and seeing if the same problems occur there, That will help us isolate whether the problem is in the code or the designer project. Let me know how you go.

  • You must to post comments
0
0

hi.
I’m sorry- I forgot to write that in sandbox everything works fine.

  • You must to post comments
0
0

It sounds like something has been set up incorrectly on the code side then. Another thing worth checking is that EventSystem::update is being called regularly (once per frame).

  • You must to post comments
Showing 13 results
Your Answer

Please first to submit.