0
0

Hey guys, first post!

Anyways, not my first run in with FMOD, worked with it back when I was at Midway back in 06, 07, 08. Loved it then and now.

On to the issue.

So we’re using Big World on our game. We have everything playing in game, but we’re running into an event with our combat sound events not playing all the way. They keep getting cut off within in a second of the sound starting. I’m not sure what is going on here.

Set max channels to 64. At this point though, other than music playing, there’s really only 2 channels being used as we’ve not plugged in environment audio yet.

All combat events are set to to 3D, World Realative, Logarithmic, Oneshot = Yes

Sound Defs are set as:
Spawn Time [0,0]
Maximum spawned sounds 1
Play mode SequentialEventRestart
All other sound def settings are defaulted

Sound Bank is set as:
Bank type Decompress into Memory
Compression MP3
Enable Syncpoints No
Compression quality 50
Optimize sample rate No
Max Streams 10

The UI Sounds which are in the same project/bank are all loading and playing with no issue.
We’re calling the events via python scripts at this time. Is there a setting that we’re missing in BW?

Thanks for any advice you can offer and keep on making a fantastic audio system!

  • You must to post comments
0
0

Hi dthecomposer, welcome to the FMOD Forum.

[quote:10l60ov6]Loved it then and now.[/quote:10l60ov6]
With that kind of flattery you could go a long way :)

[code:10l60ov6]They keep getting cut off within in a second of the sound starting.[/code:10l60ov6]
Thats’ very unusual. I cannot think of anything which would cause that behaviour inside FMOD. If you think it could be related to your project configuration try opening your built project in FMOD EventPlayer and testing out the events in there. I think it is more likely an issue with the integration itself.

When you say ‘within in a second’, that is the strangest part. Roughly how long, 50ms? 500ms? If it is the former it is possible that the 3D event is getting placed at (0,0,0) initially or on top of the listener, then is moved to it’s correct location later. I would just check that the scale of the 3D Max Distance matches the world scale inside BigWorld.

You could also try connecting FMOD Profliler to the game to see the signal flow, that will tell you if the sound has been stopped or just muted. To do that add the FMOD_INIT_ENABLE_PROFILE to the System::init call and just open FMOD Profiler and connect to 127.0.0.1

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.