0
0

Hi!

I try to play a CD with FMOD. It seems there is a problem with some SATA cd drives (here a "Lite-On iHAS324").

I start the "CD Player Example" (examples_csharp\vs2005\cdplayer) and select the CD drive. I get the following error message:

FMOD error! ERR_CDDA_NODISC – No disc present in the specified drive.

However, there is a audio CD in the drive (Windows MediaPlayer plays the CD with no errors).

I’m using the latest FMOD version (4.36.05).

Thanks

Jus

  • You must to post comments
0
0

Anyone?

Do you need more information?

Please help.

Thanks!

Jus

  • You must to post comments
0
0

This is now being discussed via support@fmod.org.

  • You must to post comments
0
0

After some testing on my system, I think fmodex requires a CD to be present in the ‘primary’ drive.
– If I have a Audio CD in drive M: only, I can play the tracks on that drive
– If I have a Audio CD in drive N: only, I can [b:220bl6f1]NOT[/b:220bl6f1] play the tracks on that drive
– If I have a Audio CD in both drives, I can play from M:, sometimes from N: too. (Worked, until I swapped the CDs -> no track of N: could be played)
– When playing from M:, I always have about 2 seconds from the first track played regardless which track I play.
– When playing from N:, I don’t have those 2 seconds.

But again, I still use Windows 98 and may be related to the OS. Just try. (just tested with FMODEx 4.09.01)

Just try with an real audio CD ("Compact disc digital audio") with no special/data tracks in any drive present (also the virtual, I guess) and try if that helps.

  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.