0
0

hello, i’m working in a windows 7 environment, using visual studio 2008 c++. i have VS spit out all memory leaks upon program termination using:

[code:2esefi6k] #if defined(DEBUG) | defined(_DEBUG)
int nOldState = _CrtSetDbgFlag(_CRTDBG_REPORT_FLAG);
_CrtSetDbgFlag(nOldState | _CRTDBG_ALLOC_MEM_DF | _CRTDBG_LEAK_CHECK_DF );
#define _CRTDBG_MAP_ALLOC
#define _INC_MALLOC
#endif
[/code:2esefi6k]

however, as soon as i add code to init my FMOD::System, visual studio no longer prints out any memory leak information. my init line:

[code:2esefi6k]mSystem->init(32, FMOD_INIT_NORMAL, 0);[/code:2esefi6k]

i see the same behavior in the examples. i am using fmodexL.dll and fmodexL_vc.lib

has anybody seen this? any ideas how i can fix this?

thanks,

mike

  • You must to post comments
0
0

I’ve just dumped that code into the playsound example and it worked. You just need to make sure you are linking with the debug library of the CRT.
i.e. C/C++ -> Code Generation -> Runtime Library = /MDd or /MTd

  • You must to post comments
0
0

[quote="mathew":2m7yktyp]I’ve just dumped that code into the playsound example and it worked. You just need to make sure you are linking with the debug library of the CRT.
i.e. C/C++ -> Code Generation -> Runtime Library = /MDd or /MTd[/quote:2m7yktyp]

thanks for the response! that did indeed fix the examples, but i was already linking with the debug lib on my actual program. any other common settings i should check out?

-mike

  • You must to post comments
0
0

None that I can think of. I can’t think of any reason why System::init would cause your logging to go away.
If you could reproduce that with the examples I may be able to debug the issue for you.

  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.