0
0

I’m working on some automatic weapon implementation using granular synthesis. I’m using the method where I set the Spawn Time min and max to 1 ms but set the sound instance Start Mode to "Wait for previous." This way it plays back each of my 70 ms gun burst files one after another.

I want to be able to vary the fire rate in a specific way. The Spawn Intensity setting doesn’t do anything because of the "Wait for previous" setting, and if I try changing the Start Mode to "Immediate," the Spawn Time min and max to 70 ms, and mess with the Spawn Intensity I get the sounds stumbling over each other and generally sounding awful.

I want to be able to keep the "Wait for previous" setting (because it sounds good) but be able to shorten the gun burst sound files by just cutting off the ends of the sounds. This way I could increase the fire rate by decreasing the burst length. I don’t know if there’s any way to do this in FMOD at this time.

The idea seems relatively simple to me. I’d basically need an effect that’s the inverse of Time offset – something that allows me to play back the sound from the beginning up to a set amount of time from the end. To use my problem as an example, I could set it to 4 ms and it would play back the first 66 ms of each burst. Immediately after this 66 ms burst finishes it would move on to the next burst waiting to be spawned. This way I’d change my fire rate from about 860 RPM to about 910 RPM.

Alternatively, an effect that you set to only play back a set amount of each file would also work. I could set it to 66 ms and it would play back the first 66 ms of any sound I run through it. This might be easier, I’m not sure.

Is there a way to do this? If not, is there any chance an effect like this could be added? Would it be possible for me to create my own effect that does this? And if so, how?

  • You must to post comments
0
0

I’m beginning to despair of ever being able to do these weapons the way I want, so I’m trying to get the spawn intensity method to work instead.

I’m running into a new problem, though. I set my spawn time to [90, 90] so that it would spawn a gunshot every 90 ms. However, the actual spawn time I’m getting is wildly inconsistent. I recorded my output to analyze it in my DAW and my spawns are coming anywhere from 70 to 115 ms apart.

I tried increasing max polyphony to different amounts, but it didn’t help. My sound files are so short that I didn’t think it would – there are never more than two sounds playing simultaneously.

Is there a way to fix this?

  • You must to post comments
0
0

FMOD is framerate bound, so the respawnings can only occur at frame ticks. So at 30fps, your maximum accuracy would be 33 ms. Unfortunately.

Anyhow, I’m having a problem with the Spawn Intensity effect now. If I add a Spawn Intensity effect to a layer that contains a respawning sound instance, the sound instance will then play only once. No matter what I set the Spawn Intensity parameter to, there is just one spawn when the event is played. If I disable the Spawn Intensity effect, the sound instance starts respawning again. What gives? (Event set to Oneshot: No; also tried Oneshot: Yes, no change)

Using FMOD Designer version 4.25.04 (Apr 30 2009). Yes, it’s very old, but they said it’s unlikely we’ll update to a new version during this project.

  • You must to post comments
0
0

[quote="Skaven":6bmsynxt]Anyhow, I’m having a problem with the Spawn Intensity effect now. If I add a Spawn Intensity effect to a layer that contains a respawning sound instance, the sound instance will then play only once. No matter what I set the Spawn Intensity parameter to, there is just one spawn when the event is played. If I disable the Spawn Intensity effect, the sound instance starts respawning again. What gives? (Event set to Oneshot: No; also tried Oneshot: Yes, no change)

Using FMOD Designer version 4.25.04 (Apr 30 2009). Yes, it’s very old, but they said it’s unlikely we’ll update to a new version during this project.[/quote:6bmsynxt]
What is the spawn instensity effect’s ‘Intensity’ setting? It acts as a multiplier to spawn time, so the default value of 0 will cause the behaviour you’ve described.

  • You must to post comments
0
0

Heya, and thanks for your reply. The answer is: "No matter what I set it to". As in, I tried setting it to a whole variety of values from 0.0 to 100.0 and it always just spawned once.

It wasn’t a case of the event stopping itself between spawnings, either (I tried "Oneshot: No" in the event’s settings).

It may be a bug in this old version of FMOD (/Designer) we’re using.

  • You must to post comments
0
0

That is odd… I’ve not been able to reproduce the issue here, even using the same version as you.

It’s possible that the problem only occurs in highly specific circumstances. It might be an idea to write to support@fmod.org with this issue, and attach your .fdp to the message so that we can get a better idea of what might be happening.

  • You must to post comments
0
0

It’s starting to look like an isolated incident now. After creating more events that use Spawn Intensity to alter the spawn rate of various respawning sound defs, I haven’t run into that problem any more. Thanks for the reply, I’ll contact support if it happens again.

  • You must to post comments
Showing 6 results
Your Answer

Please first to submit.