0
0

Hey,

Sorry to ask this, but it’s stumped me for the last couple hours (and a bunch of searches didn’t turn anything up). I’m trying to include fmod into my VS2008 project, but it’s not compiling, and I can’t figure out the proper settings to get it to link. Here’s the code:

include "windows.h"

include ".\include\fmod.h"

void InitSoundSystem(){
FMOD::System *system;
}

1>c:\users\test\soundsystem.cpp(7) : error C2653: ‘FMOD’ : is not a class or namespace name
1>c:\users\test\soundsystem.cpp(7) : error C2065: ‘System’ : undeclared identifier

The current folder structure is the main folder, which has the fmodex.dll and fmodex_vc.lib file in it, a subfolder "include" with the .h files in it, and a "lib" folder with the dll and lib files in it (for good measure :P). I have tried a number of things to get it to work. I tried putting at the top of this file:

pragma comment( lib, "fmodex_vc.lib" )

I also tried adding the paths of the two folders mentioned above in the Linker General settings under Additional Library Directories. However, I still can’t get it to work.

Any ideas?
Thanks!

Edit: I have fmodex_vc.lib as an additional dependency, and it’s definitely finding it, as it gives a different warning if it can’t find the dll.

  • You must to post comments
0
0

That’s not a linker error, that’s a compile error.

You need to include fmod.hpp for the C++ interface, fmod.h is for the C interface.
To use the C interface you would need to use FMOD_System instead of FMOD::System.

  • You must to post comments
0
0

[quote="mathew":llndeea6]That’s not a linker error, that’s a compile error.

You need to include fmod.hpp for the C++ interface, fmod.h is for the C interface.
To use the C interface you would need to use FMOD_System instead of FMOD::System.[/quote:llndeea6]

Edit: Thanks, got it working now!

  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.