0
0

Hello,

In my current C++ project I use a soundbank to store the audio files and an FMOD Designer .fev to access them via code. The bank also consists of multitrack .wavs. Everything works perfectly fine as long as I keep the bank type PCM.

As soon as I switch to compressed codecs like MP3 or CELT and want to play a sound (in the exact same way I did before), I get the following error:

[code:1ob84y7m]FMOD Error (79) – The sound created exceeds the allowable input channel count. This can be increased using the maxinputchannels parameter in System::setSoftwareFormat.[/code:1ob84y7m]

I tried different codecs and bank settings (PCM always seems to work without a problem), also tried manually increasing the "maxinputchannels" parameter, but to no avail.

Any help would be greatly appreciated.

  • You must to post comments
0
0

This sounds similar to the problems someone else was having:
viewtopic.php?f=8&t=14870

The solution was to set the bank type to ‘stream from disk’. A a side note, just be aware that it is best to separate shorts sound effects from longer music/dialog sounds, streaming short sounds is not optimal.

  • You must to post comments
0
0

Ah, I didn’t find that thread with the search function unfortunately, but it works! I will use two banks then, thank you very much!

  • You must to post comments
0
0

You’re welcome, glad to hear you got it working. :)

  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.