0
0

Hello,

I think I might be missing something obvious but am hoping someone on here can stir me in the right direction.

Is there a way in Designer to relink audio media once it’s been imported into a bank?

I had to change the directory structure of the media I was using before building a project, and as expected upon relaunching Designer, it could no longer find the media files. However I couldn’t figure out a way to relink them without having to re-import the audio files. Am I missing the obvious?

Any pointers would be greatly appreciated, thanks!
john.

  • You must to post comments
1
1

Ah, it is possible, yes. There are two different ways you could use, in fact, depending on how your project has been set up.

Your first option (and arguably the better of the two) is to change the project’s ‘Audio Source Directory’ property. This property can be found in the ‘Project Properties’ window, which you can access from the ‘Window’ menu. Your project stores the location of every source audio file as a relative path from this directory, so in theory, changing this property to the new location will result in your project being able to find the files in their new location without trouble. One caveat, however: If you did not set this property when you first created the project, there is a high chance that the relative paths of your audio files are quite long and convoluted. As a result, this method may not work – In which case, I reccomend using the second option, described in the next paragraph.

The second option is slightly more involved. First, start to build your project. In the early stages of the process, Designer will prompt you to specify the location of any missing files, and will update your project to use the new relative paths. Once you do, you can abort the build safely and continue working as if your audio files were in the correct location.

Unfortunately, neither of these features is particularly obvious. We have been meaning to to fix that, but we’ve been a bit busy with Studio…

  • You must to post comments
0
0

Thanks for the thorough response! Seems like I should have been able to figure this out on my own, so your time is even more appreciated.
Cheers!

  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.