0
0

Hey there,

One of our sound defs behaving incorrectly in-game. It messes up with stereo phasing and panning. It only happens when looking at certain directions.

I’m sure there’s nothing wrong with emitter and listener, because we’re using same system for everything similiar, and there’s no traces any problem like this. I’m also sure it’s based on sound def/sound files, because every event that uses those defs will behave bugged.

Here’s what we’ve tried so far:
– Recreate the sound def with same sounds files.
– Changing compression methods.
– Messing with randomization values.
– Refactoring the code (This made us realize that only those events and sound defs are bugged).

Also, everything sounds fine in Designer, Audition 3D and Event Player.

I’ve included a recording that will better define the problem.

Any ideas about this?

[attachment=0:3a331jk8]Fmod_Phasebug.zip[/attachment:3a331jk8]

  • You must to post comments
0
0

I cannot hear any phasing with the sounds being so short but I can hear some hard panning for some of the footsteps. I suspect the problem is that the footsteps are close to the listener. The way our panning algorithm works if something is directly left of the listener it will be panned hard left, regardless of proximity. If this is the cause of the problem, it can be mitigated using the ‘3D Pan Level’ property which effectively morphs between 2D and 3D. This allows you to limit how hard a give sound can be panned.

  • You must to post comments
0
0

Oi, thanks for quick reply, Peter!

I’ve rebuild the event from start and problem is gone now.

  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.