0
0

Hi, FMOD team,

Right now, we are using FMOD Metro Library for Windows 8 app, we just finished the first build and tried to use the local validation, but it failed, from the report, the reasons are:
FAILED
Supported APIs
Error Found: The supported APIs test detected the following errors:

API ?createSound@System@FMOD@@QAG?AW4FMOD_RESULT@@PBDIPAUFMOD_CREATESOUNDEXINFO@@PAPAVSound@2@@Z in fmodexmetro.dll is not supported for this application type. GraviluxXD.exe calls this API.
API ?getLength@Sound@FMOD@@QAG?AW4FMOD_RESULT@@PAII@Z in fmodexmetro.dll is not supported for this application type. GraviluxXD.exe calls this API.
API ?getLoopCount@Channel@FMOD@@QAG?AW4FMOD_RESULT@@PAH@Z in fmodexmetro.dll is not supported for this application type. GraviluxXD.exe calls this API.
API ?getPaused@Channel@FMOD@@QAG?AW4FMOD_RESULT@@PA_N@Z in fmodexmetro.dll is not supported for this application type. GraviluxXD.exe calls this API.
API ?getPosition@Channel@FMOD@@QAG?AW4FMOD_RESULT@@PAII@Z in fmodexmetro.dll is not supported for this application type. GraviluxXD.exe calls this API.
API ?getSpectrum@Channel@FMOD@@QAG?AW4FMOD_RESULT@@PAMHHW4FMOD_DSP_FFT_WINDOW@@@Z in fmodexmetro.dll is not supported for this application type. GraviluxXD.exe calls this API.
API ?init@System@FMOD@@QAG?AW4FMOD_RESULT@@HIPAX@Z in fmodexmetro.dll is not supported for this application type. GraviluxXD.exe calls this API.
API ?playSound@System@FMOD@@QAG?AW4FMOD_RESULT@@W4FMOD_CHANNELINDEX@@PAVSound@2@_NPAPAVChannel@2@@Z in fmodexmetro.dll is not supported for this application type. GraviluxXD.exe calls this API.
API ?setLoopCount@Channel@FMOD@@QAG?AW4FMOD_RESULT@@H@Z in fmodexmetro.dll is not supported for this application type. GraviluxXD.exe calls this API.
API ?setPaused@Channel@FMOD@@QAG?AW4FMOD_RESULT@@_N@Z in fmodexmetro.dll is not supported for this application type. GraviluxXD.exe calls this API.
API FMOD_System_Create in fmodexmetro.dll is not supported for this application type. GraviluxXD.exe calls this API.


Impact if not fixed: Using an API that is not part of the Windows SDK for Windows Store apps violates the Windows Store certification requirements.


How to fix: Review the error messages to identify the API that is not part of the Windows SDK for Windows Store apps. Please note, C++ apps that are built in a debug configuration will fail this test even if it only uses APIs from the Windows SDK for Windows Store apps. See the link below for more information"

Do you have some ideas? Thanks.

  • You must to post comments
0
0

This problem was resolved on our email support as was caused by a out-of-date pre-release version of Windows 8.

Nicholas Wilcox | Programmer
FMOD by Firelight Technologies Pty Ltd
Interactive Audio Middleware | http://www.fmod.org
PH: +61 3 96635947 Fax: +61 3 96635951

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.