0
0

Hello,

I’am using Codeblocks and get following error on compiling my programm:

[color=#FF0000:2627v0ml]libs/fmodapi44000linux/api/lib/libfmodexL.so: could not read symbols: File in wrong format[/color:2627v0ml]

neiic

  • You must to post comments
0
0

What architecture are you compiling for? It sounds like it doesn’t match the arch of the FMOD lib.

We provide x86 via libfmodex.so and x86_64 via libfmodex64.so. We do not currently have an ARM compatible version for Linux (you need source access to build this).

  • You must to post comments
0
0

Thanks for the help.

I’m using a 64bit system and i think this was the error, but where can i get the 64 bit version.
I found only [url:1ulrizfg]http://www.fmod.org/index.php/release/version/fmodapi44401linux.tar.gz[/url:1ulrizfg] and there isn’t a 64bit lib in there.

Have a nice day
neiic

  • You must to post comments
0
0

I’ve just downloaded 4.44.01 from our website (32 and 64 are in the same installer) and I can confirm in the api/lib directory there is libfmodex64, the 64bit FMOD version, can you double check?

  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.