0
0

Hey everybody,

I’m having a problem with the so-called "don’t play" entries in the sound defs panel. Actually they do work, just too well, I simply don’t hear anything in-game when using them! It doesn’t matter at what percentage they are, they simply mute the sound files in the sound def forever. So for now I have to create two events, one with they layers I always want to hear, and a second (simple event) with the sounds of the layer that should play only once in a while, along with a silence event (because those work). I’m sorry if this may be a stupid question, but from what I take from the manual, these don’t play entries should do exactly what I’m trying to, expcept they don’t. Does anyone else have this problem?

Regards,
Raphael

  • You must to post comments
0
0

I can’t be sure without more information, but I suspect the problem that you’re running into is that ‘don’t play’ entries don’t have a duration – so if you’re using a sound def that is supposed to spawn sounds repeatedly or play through a playlist of sounds, it will reach the ‘don’t play’ entry and never progress to the next item in the list.

Could you possibly provide more detail? In particular, it would be good to know how you’re using events, how you’re constructing your sound defs, and what kind of behavior you’re trying to achieve.

  • You must to post comments
0
0

Hi Joseph,

thanks for the reply! I’m trying to do the following:

In our game, whenever a character hits a creature, I want it to play a hit-taken sound. This sound is a multitrack event with usually about 4 layers, each with several files. Now, I want the creature to scream when taking hits, just not every time. So i made a layer with screams and a don’t play entry, but the creature just stops screaming entirely.

It’s really trivial, but it just won’t work for me. :(

  • You must to post comments
0
0

Just to add, I didn’t realize I wrote this so long ago, and that you answered it right away, sorry!

  • You must to post comments
0
0

[quote="bluesmornik":3gr5p66b]This sound is a multitrack event with usually about 4 layers, each with several files. Now, I want the creature to scream when taking hits, just not every time. So i made a layer with screams and a don’t play entry, but the creature just stops screaming entirely.[/quote:3gr5p66b]
Hmm, I assume you’ve got one sound instance per layer… What play mode are your sound defs using? If it’s set to some variant of ‘sequential’ then that might be your problem. Are you using play percentages or weights in conjunction with ‘Random No Repeat’ play mode? Designer 2010 has known issues with that combination.

If it’s not that, then I suggest sending a copy of your .fdp to support@fmod.org. It’s usually quicker for us to look at the project file directly than to ask you for details one at a time.

  • You must to post comments
0
0

well, this is awkward. I had erased all the different scream layers from the different creatures, now i created a new one for one of the creatures and everything worked perfectly. And I saw that the "random no repeat", and randomization by percentage is the instant choice, when a new sound def is created, right? I tried using "repeat", and it worked, too. I really don’t know what’s different now, but it works. :)

I think I’ll take "repeat", when redoing the layers, since you said that there’s an issue with the no repeat option. Thanks a lot!

  • You must to post comments
0
0

I’m glad to hear you’ve been able to find a solution, even if you’re not sure what the problem was. Still, if it happens again, don’t hesitate to send us a copy of your .fdp.

The issue with ‘Random no repeat’ isn’t severe, it’s just that it tends to throw off the accuracy of the weights and percentages. If the sound def has a large number of entries and the weighting differences are small, it’s barely noticeable. Still, if you don’t mind occasional repetition, ‘Random’ is the more reliable choice.

  • You must to post comments
Showing 6 results
Your Answer

Please first to submit.