0
0

In our project we have quite a complex multitrack event to allow us to change the audio characteristics of the various engines you can build in our game. Each engine can rev up to 12000RPM and have about 40 samples in each track (40 for off power, 40 for on power). See the screenshot below for the setup within studio:

[attachment=1:2nf2tow4]Automation-FMOD-Capture.PNG[/attachment:2nf2tow4]

If I rapidly increases the RPM of the engine it basically skips/stammers up the samples, and makes a very choppy sound. I have made a recording here [attachment=0:2nf2tow4]Stammer Example.zip[/attachment:2nf2tow4]

Would be extremely helpful if anyone has any suggestions or tips to help mitigate this.

Thanks

Also, Out of interest, why are mp3, ogg types not allowed as attachment extensions? Surely it makes sense to allow uploads of recording of problems directly?

  • You must to post comments
0
0

Did you ever solve this issue?

  • You must to post comments
0
0

It’s framerate bound, so there isn’t much you can do about it. The only thing you can do, is to restrict the Seek Speed of the parameter (parameter properties), but this will do just that: limit the speed at which the parameter can change, so if you set it too slow it will be sluggish and not respond to RPM changes fast enough. With a suitably high (fast) value you might be able to smooth out the biggest skips however.

  • You must to post comments
0
0

Have you tried auditioning the same engines in the fmod Event Player? I found my engines sounded a lot smoother when the banks were generated and tested inside the Event player…

  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.