Hi, I’m fairly new to FMOD and am stumped.

How do you change the audibility of a sound event? I (think I) know audibility is based on volume, attenuation and occlusion and may be virtual if more than 32 sounds are audible.

My problem:
I have two 2d sound events in a small project being used for the pre-game portion of the game that aren’t audible when they play. They happen to use up the most memory out of the 11 other sounds (mostly button sounds), but not by much. I have already managed to get many 2d and 3d sounds along with ambient sounds and music into the game portion. But when I play these two sounds at the beginning (one is ambient, one is a 2 second sound for logging in) there are no other sounds playing but I can’t hear them. I have tried setting the volume to 1, and I make sure that channels playing and instances active are both 1, but the audibility never changes from 0.0.

I have asked the guy who made the sounds to check all of the settings between these two sounds and the other nine and he can’t find any differences. The sounds play fine in event player and their max playbacks are 1 and 2 and are for sure 2d.

What else should I try to change the audibility? I haven’t tried to changing the priority yet, but if there are no other sounds playing, shouldn’t that not matter? And are attenuation and occlusion just properties of 3d sounds or could it affect the 2d sounds being sent to me?

So it turns out that these two sounds wouldn’t play because their fade-in was set to a value greater than 0.
Since the pre-game portion doesn’t have a game-update, eventsystem doesn’t update every tick so the volume never changes.

  • You must to post comments
Showing 0 results
Your Answer

Please first to submit.