0
0

Hello,

I have a small question and I didn’t found how can I solve this problem :-/
I have a stereo microphone where I’d like to send the right mic channel to the right speaker channel and the left channel to the left channel… ok, no problem here… But, in every sample or tutorial I just got one channel from the mic…

So the first problem, how can I capture both mic channels??

All the best :)
Alexandre

  • You must to post comments
0
0

Is the sound you create with System::createSound passing 2 as the number of channels in FMOD_CREATESOUNEXINFO, and this is the sound that is passed to recordStart?

  • You must to post comments
0
0

Hm, ok I wonder on the non working machine if you tried a different analog mic, or a usb mic, and if it works in that case. Also try recording in a recording program to see if it works in something besides fmod – if it doesnt that would point a finger to the driver otherwise we could check it.

  • You must to post comments
0
0

like this??
[code:1166kkn6]
FMOD.CREATESOUNDEXINFO _capture = new FMOD.CREATESOUNDEXINFO();

// Cria objeto de captura
_capture.cbsize = Marshal.SizeOf(_capture);
_capture.numchannels = 2; // Stereo
_capture.format = FMOD.SOUND_FORMAT.PCM16;
_capture.defaultfrequency = 44100;
[/code:1166kkn6]

  • You must to post comments
0
0

Working ๐Ÿ˜€ Thanks, I’ve found the problem, I think is something in my netbook sound card, in another computer it worked :)

  • You must to post comments
0
0

found… my P2 mic port was damaged… -_-‘
I’ve added a new one, now my netbook is stereo again xD hahaha :)
thanks for the support brett ๐Ÿ˜€

  • You must to post comments
0
0

sweet!

  • You must to post comments
Showing 6 results
Your Answer

Please first to submit.