0
0

hi .

the Mac Version of FMOD studio does not respond to the open external editor call … is there anything we should be aware of?

also .. the PC version of FMOD Studio. This does open a preferred external editor, it opens the audio file with a GUID number … the process of re-rendering the file and re-importing the file back into FMOD, does this happen automatically on save or do we have to go through a long winded export and import procedure? (this is what is happening right now, I just need to clarify if there is a quicker procedure)

thanks

  • You must to post comments
0
0

[quote="AmC":nr8gc01o]The Mac Version of FMOD studio does not respond to the open external editor call … is there anything we should be aware of?[/quote:nr8gc01o]
When attempting to open audio files in an external editor, Studio defaults to attempting to run whichever application your operating system associates with the file format, with the file name and path as an argument to the run command. I’m not sure what application your operating system associates with the file you’re attempting to edit, but it may be that there isn’t one.

If you would prefer to use a different piece of editing software to your operating system’s default, you can override the default behaviour by specifying a preferred external sample editor in the ‘Assets’ tab of Studio’s ‘Preferences’ window. (As an example of why you might do this, iTunes tends to make itself the default application associated with a number of audio file types; However, as it can only be used to audition audio files and not to edit them, it is of limited use as an external editor.)

[quote="AmC":nr8gc01o]The PC version of FMOD Studio. This does open a preferred external editor, it opens the audio file with a GUID number … the process of re-rendering the file and re-importing the file back into FMOD, does this happen automatically on save or do we have to go through a long winded export and import procedure? (this is what is happening right now, I just need to clarify if there is a quicker procedure)[/quote:nr8gc01o]
When you import an audio file into a Studio project, the file is copied into a subdirectory of the project folder, and renamed to include a GUID. There are a number of reasons for this, mostly related to stability and ease of use; However, the important point is that the sound file used by the project is the one in the project’s audio asset subdirectory, not the one that you originally selected to import. When you open a file in an external editor, it is this internally-stored file that is opened and edited – so yes, you don’t have to re-import the file in order to use the edited version, though you may need to right-click on the audio file in the Audio Bin window and select ‘Update’ from the context-sensitive menu. (The ‘Update’ menu item is just to let Studio know that you’re finished editing the file; Otherwise, it has no way of knowing when you’re done with the external editor, and won’t be able to update all the places in the project where the file is used.)

There are two situations in which an imported file won’t be copied to the project’s internal directory. The first occurs in brand new projects that have not yet been saved to a drive, as there’s no directory to copy the imported file to. In such projects, the copy is deferred until the project is saved for the first time. The second situation occurs when importing files from the directory specified in the project’s Shared Audio Source Directory property. Such files are never copied, as it assumed you want them to be externally referenced for a good reason. In both of these cases, Open in External Editor opens and edits the externally referenced file, so you still won’t need to re-import – though, again, you may need to select the ‘Update’ menu item from the asset’s context-sensitive menu.

  • You must to post comments
0
0

I just checked the 1.3.6 update ..

on Mac, the "Open in External Editor" context click moves the audio file to another audio track in the main edit page, but it does not open an external editor

Maybe this was not the version you were going to change the Mac behaviour in, but you might like to know the change in response.

  • You must to post comments
0
0

Yes, the fix was developed too late to be included in last Thursday’s release; You’ll find it in the still-unreleased 1.03.07.

  • You must to post comments
0
0

I solved it this way.
Leave blank the external editor box. and choose you favorite external editor by following the instructions on this link:

http://computers.tutsplus.com/tutorials … -mac-51413

Cheers

  • You must to post comments
0
0

Excuse the wrong name :)

FMOD1.3.5

OS 10.8.5

external editors tried : Audacity, Logic Pro, Pro Tools

Mac you can set the path, (via browse, so I can’t see how the path would be the problem) .. it’s the right click "open in external editor" that does nothing.

PC .. it works fine.

will try it on Mavericks tomorrow.

  • You must to post comments
0
0

I have same situation. I’m trying to use Sound Forge as my external editor.

My path is /Applications/Sound Forge Pro.app

  • You must to post comments
0
0

I’ve done some investigation, and have discovered that this issue is due to the way Macintosh machines handle certain kinds of paths as commands. We’re working on a fix for the issue now; It won’t be ready in time for today’s release, but it will be included in the next.

  • You must to post comments
0
0

Thanks!

  • You must to post comments
0
0

Thanks Jonathan, that info regarding PC re-import is v. interesting.

regarding Mac editor .. the external editor has already been set in the Assets preferences..

it is the actual Right click, open file in external editor that is not physically working on Mac

should have made myself more clear

  • You must to post comments
0
0

[quote="AmC":3fd003pj]Thanks Jonathan, that info regarding PC re-import is v. interesting.[/quote:3fd003pj]
Joseph, but you’re welcome, and that information applies to Macintoshes, too.

[quote="AmC":3fd003pj]regarding Mac editor .. the external editor has already been set in the Assets preferences..

it is the actual Right click, open file in external editor that is not physically working on Mac [/quote:3fd003pj]
Hmm… I can’t really say what might be wrong without knowing more about your settings, but it’s possible that that application doesn’t accept file paths as arguments, or is otherwise unhappy with the way we format our filenames and is refusing to open – or it could be that there’s an invalid character or two in the specified path. What exactly is the path specified in the preferences window? And what application have you set as your external editor?

  • You must to post comments
0
0

I just want to add my support for addressing this problem in the Mac version of FMOD

  • You must to post comments
Showing 11 results
Your Answer

Please first to submit.