0
0

Hi,
First I have to say I’m new using this technology.

I have a problem with FSB4.I created a multichannel MP3 FSB (more precisely FSB for use with Guitar Hero World Tour). There are 3 multichannel FSBs. Two of them are perfectly synced, but the third FSB seems to play the music a bit faster and then it gets out of sync. When I pause the playback, it gets back to sync, but then it again starts to get out off sync. It’s really weird, because it only happens with this one particular FSB.

If anyone has an idea what the problem could be, I would be very thankful.

  • You must to post comments
0
0

OK, I think it has to do something with the flags. The only difference between the new and original FSB are flags. I tried just changing them manually through hex editor, but I achieved only that the new FSB plays slower (and not faster as before). Is there any way in the FSBank to change the parameters and flags with which the FSB will be created?

I need specifically these:

Global flag 0x40 – FMOD_FSB_SOURCE_MPEG_PADDED4
Sample flag 0x10000000 – FSOUND_MPEG_LAYER3

This is the only difference between those FSBs.

  • You must to post comments
0
0

This might be a version issue. I think you’re saying you want to add those flags and they’re not there? The most recent version of FSBank has this flag.

  • You must to post comments
0
0

No, they are there, but I need them to not to be there. I need FSB version 4, not the most recent one. Just changing them in hex editor didn’t do the trick, so I assume it has to be done in time of creation of the FSB, so it is not padded?

  • You must to post comments
0
0

Now I’m thinking it is not possible… I tried to extract and reencode the original file, didn’t change anything, and still it has the same problem.

  • You must to post comments
0
0

That sounds odd, but maybe check your source sounds are all the same sample rate, and same length? If so there shouldnt be a problem.

  • You must to post comments
0
0

Yes, even if I put the same file into two separate FSBs, the second one plays faster… I call shenanigans on this.

  • You must to post comments
0
0

It might be something to do with the code making assumptions about the content. You should match the original content in sample rate and channel count as closely as possible. I dont know what else, if you had code you could check this more.

  • You must to post comments
Showing 7 results
Your Answer

Please first to submit.