0
0

Hi,

We’re experiencing a strange behavior when deploying our game on Linux.
Everything works fine (soundwise) on Windows & Mac OS X but on a fresh Linux install (Ubuntu 13) we’re getting an ERR_FORMAT
each time we try to play a music or sound.

Both are played as layered events if memory serves well and we exclusively use the OGG format.

fmod seems to initialise itself correctly, we can seen it opens FSB and FSV packages correctly.

Are we missing drivers or something ?
We have videos with audio playing as streaming assets and sound output is working fine, so at least we know this not a sound output problem.

Note: The revision number of the libs we’re using is 4.44.14

Best Regards,
Malek – Amplitude Studios

  • You must to post comments
0
0

Just to clarify, you mention you are using the FMOD Unity C# wrapper? This is an integration with the FMOD Studio runtime, not FMOD Ex.
Are you possibly using a modified version compatible with FMOD Ex, or are you having these issues with FMOD Studio?

You should be able to switch to the logging version of FMOD by modifying the C#, change the dynamic library it looks for to be the ‘L’ version.

  • You must to post comments
0
0

We’re having the same problem. I’ve tested with FMOD Ex 4.44.34, and the following is the log output when we try VORBIS file loading on Linux. Our PCM/WAV files are loading normally.

[code:1zlelkxh]FMOD: EventI::stopInternal : 0x2d953868 1
FMOD: EventGroupI::loadEventDataInternal : m_flags: 00000000
FMOD: SoundBank::createStreamInstance : ev=0x2d953868 evmode=0 mode=1572936
FMOD: SystemI::createSoundInternal : filename =..../PA_VO.fsb : mode 081800ca
FMOD: SystemI::createSoundInternal : exinfo->cbsize = 216
FMOD: SystemI::createSoundInternal : exinfo->suggestedsoundtype = 7
FMOD: SystemI::createSoundInternal : 20 codecs found. Scan all until one succeeds
FMOD: CodecFSB5::openInternal : attempting to open as FSB5..
FMOD: CodecFSB5::openInternal : FSB contains 416 sounds
FMOD: CodecFSB5::openInternal : FSB contains FMOD_SOUND_FORMAT 15, which is not supported on this platform!
FMOD: Codec::release :
FMOD: CodecFSB5::closeInternal :
FMOD: CodecFSB5::closeInternal : done
FMOD: Plugin::release : (0xa4cdaa8)
FMOD: Plugin::release : done
FMOD: Codec::release : done
FMOD: CodecFSB::openInternal : attempting to open as FSB..
FMOD: CodecFSB::openInternal : Header check failed. Not an FSB
FMOD: Codec::release :
FMOD: CodecFSB::closeInternal :
FMOD: CodecFSB::closeInternal : done
FMOD: Plugin::release : (0xa4cdaa8)
FMOD: Plugin::release : done
FMOD: Codec::release : done
FMOD: SoundBank::createStreamInstance : createSound failed 25[/code:1zlelkxh]

I looked up what FMOD_SOUND_FORMAT 15 is, and it is in fact FMOD_SOUND_FORMAT_VORBIS. Nothing else in the logs about vorbis

Any idea what could be wrong?

  • Jørgen.
  • You must to post comments
0
0

It looks like FSB Vorbis is currently disabled for Linux in FMOD 4.
I can probably get that enabled for our next release as I’d say its omission is an oversight.

  • You must to post comments
0
0

Great, thanks! Is there an estimated release date for the next update?

I’m wondering if we should switch to PCM for the time being, or wait for the update.

  • Jørgen.
  • You must to post comments
0
0

We are planning a release for tomorrow, the fix will be available in that version.

  • You must to post comments
0
0

Hello, was this in the .35 release?

  • You must to post comments
0
0

[quote="Shival":26bl8u8j]Hello, was this in the .35 release?[/quote:26bl8u8j]
Yes, it was, and it fixed the issue for us! Thanks mathew!

  • You must to post comments
0
0

Hi,

Yes It works perfectly, thanks :)

Regards,
Malek, Amplitude Studio

  • You must to post comments
0
0

Can you try linking with the logging version of FMOD? It should give some indication about the error.
Also 4.44.14 is quite old, have you tried the latest?

  • You must to post comments
0
0

Hi,

Thanks for the reply.

IIRC we tested with both 4.44.29 & 4.44.34 too and we had the same problem.

The thing is we’re using the Unity C# wrapper of fmod thus I don’t think I can enable the logging version of fmod in any way
unless there’s a #define or something that toggles more verbose logging.

I’ll provide the Unity console output ASAP in case it can be helpful as well.

Regards,
Malek – Amplitude Studios

  • You must to post comments
Showing 10 results
Your Answer

Please first to submit.