0
0

Hi there,

I just updated my FMod Studio version to the latest build without realizing that the banks would be incompatible with the current Unity Integration version. Do we have an ETA on the Unity Integration update as I’m now in a bit of a pickle not being able to work in Unity until this is sorted.

Thanks

  • You must to post comments
0
0

Thanks Peter, great stuff. By any chance is there a changelog as certain things seem to be broken now and it would be good to know what has changed exactly so we can find the cause.

Thanks again

Justin

  • You must to post comments
0
0

Hi Justin,

Sorry no change log yet, here is a short list of some of the changes:

changed UnityUtil.to3DAttributes to take an optional rigidbody as the second parameter – this is to prevent the overhead of retrieving it from the gameobject
changed FMODListener and FMODStudioEventEmitter to cache their rigid body at startup – performance optimization, note that if you’re programmatically adding/removing rigid body from a GameObject using a FMODStudioEventEmitter the rigid body wont get updated any more.
updated wrapper and binaries (DLLs) to 1.04
changed FMODListener and FMODStudioEventEmitter to set their 3D position before starting to prevent possible glitch on start up
updated C# wrapper

  • You must to post comments
0
0

Just posting an agreement to the above poster. I had another question, but I’m removing it because I am hoping that the new features in 1.04 will allow me to get something specific going with Unity. But until this is resolved, I can’t work. Hope it gets resolved soon!

  • You must to post comments
0
0

Hi Peter,

Thanks and no worries, had a feeling the update might be this week, doesn’t matter too much now anyway, my main work mac decided to blow up over the weekend and my backup systems are too underpowered to run our current project so I’m on hold until things get fixed 😥 . Thanks for the update though, much appreciated.

  • You must to post comments
0
0

Yes. That would be very nice –
since I’m not able to continue my work like this, cause the new banks broke my project. ^^
This is urgent !! – Please Hurry 😆

  • You must to post comments
0
0

Unity integration for 1.04 is now available from the [url=http://www.fmod.org/download:ov6e742f]downloads[/url:ov6e742f] page.

  • You must to post comments
0
0

Hi guys, sorry for the delay, just a few bumps to iron out while we get the new platforms including linux added. Should have something for you this week, hopefully in the next day or two.

  • You must to post comments
Showing 7 results
Your Answer

Please first to submit.