0
0

Hello all,

it seems that FMOD Studio v1.04.02 breaks linking iOS 5 projects on Xcode 4.2 / Mac OS X 10.6.8. Clang says:
Internal error: atom not found in symbolIndex(___umoddi3) for architecture armv7

Is iOS 5 on armv7 obsoleted with this release (no mention in the release notes)?

Regards,

Robert

  • You must to post comments
0
0

Hello Robert,

This isn’t an intentional breakage, but it could be a side affect of us building with newer compilers.

We follow the Apple App Store submission requirements as closely as possible (sometimes we lag a bit behind).
Currently Apple require submissions compile using Xcode 5.1.1 as seen here:

https://developer.apple.com/news/
[quote:35fgjxn3]Build Your Apps With Xcode 5.1.1
April 25, 2014
Starting May 15, 2014, new apps and app updates submitted to the App Store must be built with Xcode 5.1.1. This release is available through Software Update on the Mac App Store.[/quote:35fgjxn3]

It’s possible this produces an incompatibility with your code compiling with Xcode 4.2.

  • You must to post comments
0
0

OK, thanks!

  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.