Closed
0
0

Hi all,

I’m using the GVR Plugins with FMOD in Unity and in one scene they playback with extreme distortion. It sounds like a stereo crackling noise layered over the whole 3D mix. When I disable the sounds and enable them only once the scene has been started, they play back normally. Any ideas what this could be? This also seems only to happen to sounds in one area of the scene. Other sounds in another room play cleanly.

I played with the buffer size and although that helped a bit, it did not make the noise go away entirely.

Cheers,

  • Ben
  • You must to post comments
1
0

Hi Benjamin,

That does sound odd, but it will be hard to tell where the issue lies without seeing your projects.

  1. Could you please post a screenshot of the settings of a GameObject that does have distortion and a screenshot of a GameObject that does not?

  2. Are these objects playing different events or the same event?

  3. Are there any return buses/sends being used on these events?

  4. Are there any snapshots/reverb zones being used in this scene?

I look forward to your reply.
Richard

  • You must to post comments
0
0

Hi Richard,

Thanks for your reply. I’ve posted a link to a dropbox folder with some screenshots.

https://www.dropbox.com/sh/ltxbanfiwuqyfht/AAA9F1XIoS7co2JxbL-k-NsFa?dl=0

  1. Since playing around with this issue the entire scene is broken and all sound plays back with this crackling noise. I posted, therefore, the settings of a healthy FMOD object from a scene with no issue and a similar object from a different scene.

  2. All objects are playing different events.

  3. I am sending the sounds only to various groups for mixing purposes. I’m using no buses for FX. I noticed though, that one FMOD event, although routed to one group, was coming out of a second as well. I don’t know whether this has anything to do with my original problem, but it is an issue of its own.

  4. I’m not using any snapshots but there are some Google Reverb Zones in the scene. I also just had the problem that one part of the scene played back cleanly until I added a Google Room to it. The sounds then started to have the same problem. However, when I undid my room addition, the sounds were still broken and deleting all the rooms doesn’t seem to fix the problem. I also fixed the issue once by disabling the box collider on one of the sound objects, but when I moved it the problem came back and when I undid until before the move the problem did not go away.

I’m really quite confused as to what is going on and without a fix, will have to drop FMOD completely for another solution, as my deadline is coming up. I’d be really grateful if you had any tips that would prevent me from having to do all this work over again.

Cheers,

  • Ben
  • Richard Simms

    Hi Ben,

    Thank you for your reply. I understand your frustration so I hope I can help you with this.

    It is possible that there is more than one Google VR listener in your project which is causing distortion. Could you please check affected events’ tracks and their return/group buses for any additional listeners? In fact, it looks like your “Doors” group bus definitely has a listener on it from the looks of your mixer screenshot.

    There should only be one listener on the Master Bus in the mixer.

    If this does not help, would you mind sending a sub-section or your whole FMOD project to support@fmod.com for us to investigate further?

    In terms of your Unity errors, the first one appears to be that you haven’t got a valid name for your scene and that there are no scenes to be built in Unity. This is more of a Unity issue so you will need to contact them to troubleshoot further. The FMOD errors appear to be from the play editor exiting before the FMOD system has initialized. Try restarting Unity and giving the editor ample time to start playing the scene.

    Let me know how you get on with this.

    Thanks,
    Richard

  • You must to post comments
0
0

I was worried I’d messed up something in the groups so I deleted all groups and had all sounds going through one. Suddenly, no sounds are passing through the one group anymore and are simply popping up on the master fader.

  • Richard Simms

    Hi Ben,

    This is the expected behaviour. The way the Google VR plugin works is that it directs sound straight to the Google VR listener (which should be placed on the Master Bus). The group buses are ignored.

    If you want to process the signal of your events, you will have to do it upstream of the GVR Source effects (i.e.: in the events’ audio tracks’ signal chains) or downstream of the GVR Listener effect (i.e.: in the signal chain of the bus that holds the GVR listener effect, or in a bus that that bus routes or sends a signal to.).

    Thanks,
    Richard

  • Benjamin

    I had the google listener on my group though, as I have one or two 2D sounds that need to play. According to Google’s manual, this is a way to separate them. Regardless of this, the sound came out of the master bus directly and did not seem to go through the group.

  • You must to post comments
0
0

Hi Richard,

I’ll be sure to send a copy to you guys, because I played around with the listener plugin and it didn’t change the particular problem we are having. First, I now read about how the listener plugin works but in my project, even though I misunderstood and routed the audio through groups with their own listener plugins, I was receiving normal audio output from the groups, i.e. separate signals, which speaks against the user manual that says all audio will be routed directly through the listener plugin no matter how i is routed.

Also, I then changed the project so that there is only one listener on the master bus and the problem with the distortion continued.

Also, the FMOD errors have popped up several times despite restarting the project.

Thanks again for your help,

  • Ben
  • Richard Simms

    Hi Ben,

    Were you able to send off a copy to our email address? Please let me know if you require further help.

    Thanks,
    Richard

  • Benjamin

    Hi Richard,

    I figured out the problem. I had changed the listener setting before with no success, but evidently, I had to restart Unity for the change to be fully recognized. Once I did this the issue was gone.

    On a separate note, have you heard of any work-arounds for the fact that one can’t process sounds in groups with the Google plugins? I’m realizing that, for our more complex sound design, I may have shot myself in the foot choosing this product and am not experienced enough with FMOD or Unity to see any potential solutions to this issue.

    Thanks again for your help.

    – Ben

  • Richard Simms

    Hi Ben,

    Glad to hear you resolved your issue. I’ll be sure to make a note in our future documentation about restarting Unity.

    The Google VR plugin is a custom made DSP set that are made by Google, so it is unfortunately out of our control.

    There is a *highly* unrecommended workaround using transceivers. They are very limited in use because there’s only have thirty-two different transceivers there’s a very limited number of them that you can use, and they tend to break down the moment you want to have more than one instance of a given event.

    Thanks,
    Richard

  • You must to post comments
Showing 4 results