0
0

When I place 3D objects into my VR scene, the attenuation does not work. It seems that the listener position and camera/hmd are not one and the same. This is a particular nuisance when in ‘simulate’ mode. However, when I drop the 3D sounds using Unreal only- it all works properly.

FMOD v1.09.02
UE v4.14.3

  • Cameron Baron

    I have been able to use FMOD attenuation in the HMDLocomotionMap, from the Virtual Reality template.
    Are you getting any errors or warnings at all?
    Does it work in VR Preview or Selected Viewport?

  • You must to post comments
0
0

No errors. In VR preview it plays without any attenuation settings. ie as an ambience only. Selected viewport works in a static mode. ie if the camera is close the sound is loud. If the camera is away, the sound is lower. However, when I move the camera, no attenuation takes place. I have a feeling the issue is in the camera setup in UE for this particular job. I have to finish the job today so have made it work – but will do some more testing in the following weeks. My other projects have been fine, just this one has had the issue.

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.