Answered
0
0

Hi All,

I’m having trouble building a Unity project using FMOD for Linux.
When running the build, I get the following error in the terminal:
Unable to preload the following plugins: libfmodstudioL.so

In the game itself, I get this output to the Development console:
DllNotFoundException: fmodL

From the terminal output, all other FMOD related plugins preload correctly (libfmod.so, libfmodstudio.so, libgvraudio.so).

Here are the various version details:

  • Bank built using FMOD Studio 1.09.06
  • Unity Integration 1.09.06 (package is fmodstudio10906_v2.unitypackage)
  • Unity 5.6.1f1
  • Ubuntu 17.04

This is happening in a completely new Unity project with only the FMOD package imported. It is using a Studio Event emitter to trigger a single FMOD event on object start, so there is no custom code in this project. I’ve attempted making the build from both Windows and OS X with the same results.

Searching this forum and elsewhere hasn’t turned up much for this issue, so any direction would be greatly appreciated.
Please let me know if there’s any more information I can provide to assist troubleshooting.

Thanks!
Dave

  • You must to post comments
Best Answer
1
0

It looks like Unity isn’t copying libfmodL.so into the build directory for some reason.

I will investigate this further, can you confirm it works when you can manually copy the file into “Build/Plugins/x86_64”?

  • David Reece

    Thanks for the response!
    Just tested this, and copying `libfmodL.so`over into “Build/Plugins/x86_64” has the build running in Linux.

  • Cameron Baron

    It looks like an issue with the meta file for the lib, I will make sure this is fixed in our next release.

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.