Answered
0
0

Hello all,

We just upgraded our FMOD Studio and Unity integration from 1.04.12 to the current stable release (1.05.12), and now our game throws 30 errors when launching stating “License error. This plugin is only supported in Unity Pro!” (http://puu.sh/fzjZL/d4c69c498c.png).

We are developing an Android game using Unity’s free version, and we are not using any external FMOD plugins. The game’s audio still runs perfectly fine despite these errors, but most of the time a call to the FMOD_StudioSystem or FMOD.Studio classes is made, this error is thrown.

FMOD Studio, FMOD Studio API and the FMOD Unity package were all upgraded to 1.05.12 simultaneously. The sound banks were rebuilt and reimported using FMOD Studio 1.05.12 before seeing this problem. In addition, trying to go to the FMOD > About Integration submenu in Unity shows an error popup saying that “../fmod.dll is in use and cannot be overwritten, restart Unity and try again.”

Any advice would be much appreciated.

  • You must to post comments
Best Answer
1
0

Shutdown unity and delete any copies of fmod.dll and fmodstudio.dll in your Unity project directory that aren’t under the Assets\Plugins directory.

  • James
    There was indeed an fmod.dll and fmodstudio.dll in the root of the project, but removing them spawned a whole collection of fmod.dll not found errors instead. I simply deleted all FMOD files, assets and banks from the project and reinstalled the .unitypackage and the license errors disappeared, with no more fmod/fmodstudio.dll in the root directory. Thanks!
  • Jussi Elsilä
    I'm running FMOD Studio Unity Integration version 1.05.12 on Yosemite. I tried to delete all the FMOD files from the Unity project and import the .unitypackage again but the problem still exists. I'm having from five to seven warnings saying "License error. This plugin is only supported in Unity Pro!". My FMOD Studio is also the recent one and have tried to build banks and import them, but nothing works.
  • Sander H.
    Same here: Integration 1.05.12, Studio 1.05.12. Deleted and replaced all FMOD assets (also from the project root), reimported, rebuilt banks, deleted the files, everything works fine but I get 19 license errors. (Working on OSX).
  • Nicholas Wilcox
    I've added a separate answer to the question for OSX.
  • Sander H.
    On Windows 7 we are not able to remove this error from Unity Editor. Audio plays fine and builds work fine, but in the editor we get 19 of these errors, even after closing Unity and deleting everything that has to do with FMOD and reimporting the package. Hellllpppp! :D
  • You must to post comments
0
0

For OSX users encountering license errors with Unity Free. Shutdown Unity, and delete fmod.bundle and fmodstudio.bundle from the Assets/Plugins folder under your Unity project.

  • Sander H.
    OK, this fixes the issue on OSX. Thanks.
  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.