Answered
0
0

I have a particular event I’m testing with, and I set the channel volume all the way down, and couldn’t figure out how to change the instance volume to hear it.

Simply typing Instance->setVolume(1.0f); didn’t seem to work. I can use it to go down in volume but not up.

I tried instead to change the master volume all the way down, and still couldn’t hear it. Since I want the audio to start muted, I assumed I had to adjust that volume in FMOD Studio prior to building the banks. If I don’t lower the volume/mute the audio FMOD Studio when I build the banks, the event instance plays fine and I can use setVolume to change the volume to make it lower. But since its suppose to be muted first, then how can I raise the volume in game during runtime, so it isn’t heard at first, but then later?

  • You must to post comments
Best Answer
0
0

The volume set by the API is combined with the volume set in Studio, so setting the runtime to 1.0 is going to multiply by 1, rather than override the Studio value.

To have a sound start quiet you can set the volume at runtime to a low value and then bring it up to 1.0 over time.

To make sure it isn’t loud at the start, you can create the event without playing it, then set the volume, then play the event. You can do that via blueprint actions in UE4.

  • Tim Robinette

    So if I understand you correctly, if I have several FMOD audio sources playing audio that I want all quiet, and heard at certain times, I would have to search for them all at the start of the application to lower the volume of each one?

  • Geoff Carlton

    Yes that will work. Another way is to set up the events with a volume automation on a parameter. That way the volume can start low, and then can increase as you set a parameter value.

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.