How do I pan a sound so that it only plays in one stereo channel?
I want 100% of the sound to play in one channel, and 0% in the other.
When I pan the sound all the way to the right, I want to be able to take out my right earphone, keep my left in and not hear the sound playing AT ALL.

I have been trying to do this for hours now.
It feels like it should be the easiest thing in the world to do, so I’m really, really, really hoping that I’m MISSING something obvious.

I’ve tried:
-making the sound 2D and 3D
-made it stereo and panned it all the way over to one side
-made it surround and activate one side of the speakers and disable the other side, along with moving the 3D position all the way over to one side, as well as reduce the distance attenuation as much as possible, and even turn it off
-added a channel mixer and used it to completely mute one channel

I’ve tried all of these methods, and more that I don’t even remember right now, both on the sound event itself directly, and on the mixer it’s playing through.

What makes me so frustrated is that I have managed to pan the sound all over to one side with several of these methods, but a little bit of sound is ALWAYS bleeding over to the wrong side.
I can look at the master bus, see that sound is being played ONLY on one channel, and see NO SIGNAL AT ALL on the other channel, but I can STILL HEAR THE SOUND on the wrong side.

I can throw the sound file into any other audio editing software and pan the sound to one side and have this done in 10 seconds.
Why is it so fricking impossible to do it in FMOD?

Please tell me what I’m doing wrong, this HAS to be possible in FMOD, and it HAS to be really fricking simple…

  • You must to post comments
Best Answer

Thank you for your input Brett and Richard.

After a couple of days I managed to solve my issues.
On one of my computers I was simply doing it wrong, and on the others it was being caused by Dell’s wonderful audio drivers, probably in line with your first response Brett.

I’m able to manage the audio just the way I want to now.

Thanks, sorry and good bye.

  • You must to post comments

This is most likely not FMOD. If the metering shows no signal, then there is no signal.
I would be checking your sound card settings for ‘headphone’ spatialization and the like. Turn off any processing or fix your windows speaker mode so that it matches your speaker setup correctly.

  • Robin Gerndt

    What do you mean?
    Did you read my entire post?

    The problem lies with FMOD (most likely me not using the right method).

    It has nothing to do with my sound card being unable to play sound properly.
    I’m getting the same result on 3 different computers.
    I’ve used 2 different versions of FMOD: 1.09.03 & 1.10.02

  • Brett Paterson

    Apologies for the delay, I am not handy to a pc to test but it might be something to do with the SRS mix down from 5.1 to stereo which is a 3rd party plugin. Try setting your project to 7.1 or stereo in the studio preferences to avoid the down mix, there might be some sort of headphone processing going on

  • You must to post comments

Hi Robin,

I’ve done some testing internally and here’s what I’ve found:

The behaviour you’ve seen (panning hard right, some sound still being played in the left channel) appears to have been some kind of strange down/up mixing on the operating system side.

When I had headphones plugged into a laptop’s headphone jack, I would get the behaviour you’ve described regardless of what is happening in FMOD. When the headphone jack is not being used (unplugged) then the expected behaviour (only right channel produces audio) occurs. I tested this by recording the speaker output directly into Audacity.


  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.