Answered
0
0

I’m seeing an error that appears to be related to FMOD trying to load something.

The error is below:

10-05 04:00:54.641: I/Unity(21391): AndroidJavaException:
java.lang.UnsatisfiedLinkError: dlopen failed: cannot locate symbol
“__aeabi_atexit” referenced by
“/data/app/com.bsgbryan.jumpymcrunface-2/lib/arm/libfmod.so”…

Full disclosure: I’m an Android n00b. I have the Android SDK, Java JDK, and Android NDK installed and configured in Unity. My game builds properly on iOS/tvOS/macOS devices. I’m just getting the above error when I run my game on my test Nexus 5.

I’ve googled around and can’t find anything related to this specifically.

Versions for everything I’m using:

FMOD Studio: 1.08.11, 64 bit, Build #79819
Unity: 5.4.1f1
Device: Nexus 5 running Android 6.0.1
In unity, I have the minimum Android version set to: 4.1 ‘Jelly Bean’ API level 16

I’d really appreciate any help, thanks!

And if there’s any additional info you need, please just let me know!

  • You must to post comments
Best Answer
1
0

This is known issue with our 1.08.11 release, please update to 1.08.12 or newer.

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.