Answered
1
2

When i build my simple unity games including roll-a-ball, i dont get any audio in the game.

when i build for web player i get this error: Assets/Plugins/FMOD/Editor/FMODEditorExtension.cs(183,47): error CS1061: Type System.IO.DirectoryInfo' does not contain a definition forGetFiles’ and no extension method GetFiles' of typeSystem.IO.DirectoryInfo’ could be found (are you missing a using directive or an assembly reference?)

when i build for mac osx i dont get any errors but either way the build has no audio.

Can anyone help me?

thanks.

  • You must to post comments
Best Answer
0
0

Hi Adriano,

The most likely cause of having no sound in the game is have a 3D panner with a max distance that is too small. The 3D panner will make the event silent when the distance to the listener is greater than “max distance” which defaults to 20. Either remove the 3D panner from the event or increase the max distance.

The integration does not support webplayer so those errors you’re seeing for that platform are expected.

  • Adriano Martin
    Hey Pete, Thanks for the response. I do not have any 3d panners in the project and the game plays flawlessly in the unity editor. The builds just dont have any of the audio.. So Fmod integration isn't supported in web player builds?
  • Troy
    Just wanted to say I have the same problem. I can play my scene in Unity and hear everything fine. When I build it, there's no sound. Oddly enough, when I select "Build and Run," the build that immediately pops up plays audio fine. When I click on the exe file in Explorer, though, there's no audio (and I'm sure I'm clicking on the correct exe). I'm on Windows 7 for what it's worth. I had been using Fmod Studio 1.5.00, but just updated to the latest version (1.5.06), and there was no change. Still works fine in Unity, but the build doesn't have any audio. And to be clear, I'm just doing the PC/Mac/Linux build.
  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.