My UE4 (4.12.4) projects works with FMOD Studio plugin just fine. However, I need to use FMOD plugin for Android from Oculus Audio SDK (since it’s more performance optimized for Gear VR).

I followed instructions for FMOD plugins, however, .so files are not located in Android/ folder, but in a subfolder. I tried placing Oculus’ FMOD plugin into Android/ and Android/ar.. subfolder, plugins.txt with the filename inside into the same folders and at the end of the day my deployed project either crashes when launching on the device, or simply runs and can not find the plugin.

If someone from FMOD could provide me with contact info, I could send you debug log files from Gear VR.

Thanks beforehand

  • You must to post comments
Best Answer

Here are the steps to get it up and running. I tested it with Oculus 1.0.4, but our last public release has packed up an older version. So the steps will include copying the libraries from the Oculus SDK into the FMODStudio plugin.

This was done a fresh code proeject in Unreal 4.12, using FMOD Studio 1.08.04 in the game’s Plugins directory.

  • Copy the latest 1.08.04 Oculus libraries into the FMODStudio plugin:

    • Copy AudioSDK\Plugins\FMOD\x64\ovrfmod.dll into FMODStudio\Binaries\Win64\
    • Copy AudioSDK\Plugins\FMOD\x64\ovrfmod.lib into FMODStudio\Binaries\Win64\
    • Copy AudioSDK\Plugins\FMOD\android\ into FMODStudio\Binaries\Android\armeabi-v7a
  • Copy the latest 1.08.04 Oculus libraries into a FMOD Studio (either a Plugins directory where FMOD Studio is installed, or a Plugins directory under your FMOD Studio project directory)

  • In FMOD Studio:

    • Create an event, and replace the panner with an Oculus panner.
    • Go to Preferences -> Build and add Mobile platform, with default settings.
  • Make sure the FMOD Studio project exports into the game Content directory. You can do this with UE4 Help -> Validate FMOD. It will fix up FMOD Studio project output path and also add FMOD to the additional directories to copy.

  • Make sure the Oculus plugin is enabled. For most plugins, this would be done by the “Plugin Files” setting, but for Oculus, you can just tick “Oculus Enabled” under the FMOD Studio Oculus section.

  • Make sure the banks are exported.

  • At this point you should be able to drag an event into the level, and PIE and hear it.

  • For deployment on Windows, you need to create FMODStudio\Binaries\Win64\plugins.txt with the following line:


  • For deployment on Android, you need to create an APL file. Luckily the FMOD docs have an example that shows exactly what you need for the case. Look at the “Deployment of Android plugins” section in

  • Create FMODStudio\Binaries\Android\ovr_APL.xml and paste the xml from the above page.

  • Launch on Android. As it is building, you should see your file referenced in the output window, something like:

    LogPlayLevel: UnrealBuildTool: Adding YourGame\Plugins\FMODStudio\Source\FMODStudio\FMODStudioL_APL.xml
    LogPlayLevel: UnrealBuildTool: Adding YourGame\Plugins\FMODStudio\Binaries\Android\ovr_APL.xml

  • Also, have a look at the intermediate directory YourGame\Intermediate\Android\APK\libs\armeabi-v7a. There should be the two fmod .so files, as well as the file. If they aren’t there then it mustn’t have used the APL file properly.

  • The game should launch and play on Android.

  • Alex Zubov

    Yep, that did it, thanks! (except now I don’t get spatialized sound played; probably doing something wrong)

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.