-1
0

I’m fairly new to FMOD Studio, and I was wondering if someone can help me out.

I’ve created two, one shot events (swing and bite) that is suppose to trigger a sound as a enemy takes damage. Within the two events I have a created a parameter tab called “Surface” so if the “swing” event is triggered, and the surface parameter is set to 1 a metal clank will be triggered as well. Or conversely if the “bite” event is triggered, and the surface parameter is set to 2, I will hear blood squirting out. Then I created a new one shot event called “Damage Enemy”, in which I added a parameter tab called “Weapon type” where I copied the two event swipe = 0 and bite = 1 to the weapon type parameter of “Damage Enemy”. I also added the parameter “Surface” to the “Damage Enemy” event where the “Surface” parameter is exactly the same for the “Bite” and “Swing” events. I assign the events to a bank, and then I build my platform and import the banks into Unity.

In the Unity console log, the events “swing” and “bite” seems to play fine in the FMOD event browser in Unity, it plays and stops (Preview event – count 1, length = 2000, state = playing, and then stopping). However if I play the event “Damage Enemy” when the parameter set to 0 = Swipe or 1 = Bite, it plays the initial sound but the audio never stops, as if its in a constant loop (Preview event – count 1, length = 0, state = playing). Because of this state I believe that is the cause of why I can’t hear the triggered sounds in Unity. Can any one shed some light into what I am doing wrong?

  • Joseph Harvey

    Unfortunately, without more information about the design of your FMOD Studio events, it’s impossible to answer this question. Could you perhaps send a stripped-down copy of your project to support@fmod.com so that we can examine it?

  • You must to post comments
Showing 0 results
Your Answer

Please first to submit.