Answered
0
0

Hello there.

I have a question about parameters, and it is quite urgent as we’ll ship our game soon.
On this video you can see that I have sound modules in a parameter section.
What I wan’t to do is playing randomly some sound modules based on a parameter random modulation. But, as you can see, if I enter a parameter in studio that is the end of a module and the beginning of another module, both modules are playing. What should I do to avoid two modules playing? Is it a bug?
Thanks !!!

Video

  • You must to post comments
Good Answer
1
0

This is a known bug; The final position of a sound module’s trigger region is not supposed to count for the purposes of triggering the module.

The easiest way to avoid multiple sound modules being triggered by the same parameter value is to ensure there is a small gap between the sound modules on that parameter.

Note that all parameters are floats, which means that the odds of a randomly generated parameter value being exactly that at which one sound module ends and another begins is extremely small; Depending on the content of your event, the effect of this bug may be negligible.

  • Tomavatars

    Ok thanks. Actually, as it concerns music, it would be bad if two sounds overlap. So for the moment, I’ll add a very tiny gap that if triggered would result in silence, better than loudness mess. Do you have an idea if you will debug this feature soon? Thanks!

  • Joseph Harvey

    I’ve added the issue to our bug tracker, but it’s yet to be assigned a priority or scheduled for fixing, so I can’t provide an ETA at this time except to say it will be fixed in an upcoming release.

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.