Answered
0
0

(I’m not sure if this is the right place for this question)

I’m working on a game with another programmer who is dealing with the audio side of things, using our engine coded in C#. I’ve noticed that when we play most sounds, PC sounds get noticeably quiet to the point where you can’t hear it. Music is the one that you can notice the most.

This doesn’t happen when playing the same sounds in FMOD studio, and I haven’t noticed it happening in other games.

I don’t know if it’s a setting or something that we’re missing. Any help or pointers in the right direction would be very much appreciated, thanks! :)

  • You must to post comments
Best Answer
1
0

If sounds outside you game are being affected then Windows thinks your application is a communications application and is ducking all other sounds.

Right click on the speaker icon in the windows taskbar, select Playback Devices, then click on the Communications tab.

ducking

  • Micah

    I tried changing this setting but it didn’t affect anything. However, the other programmer I’m working with said this made sense, and he’ll try to figure out how to make Windows recognize that our game is not a communication app. I’m going to have to wait until he’s had time to mess with it.

    I’ve also done some tests with other games and programs and I’ve noticed that certain programs seem to have a sound priority over other programs. When sounds and music are played on the first program, sounds in the second program are muffled.
    Adobe Audition and FMOD Studio seem to have priority over windows media player, while the games I tested have a lower priority than windows media player.

    Is this something that exists with Windows? A “sound priority”?

  • Nicholas Wilcox

    Other things you can check: check your driver doesn’t have it’s own “limiter” effect by selecting the device -> properties -> Enhancements tabs. Also worth checking for updates to your audio drivers.

  • You must to post comments
0
0

Hi Micah,
The first thing I would suggest is to use the Profiler window in studio to watch what is going on, you can see levels, instance information, position data etc. It might help you find something wrong.

If your music has a 3d panner, maybe you need to remove it (click on it and hit del) because maybe as you travel in your world, the music is at 0,0,0 and just getting further away?

  • Micah

    My trouble is not the music in game, it is with the music playing on the PC. When sounds are in game, it seems to drown out the music that’s playing on the PC through something like windows media player.

    What is weird to me, is that it does not happen when listening to the exact same sounds in the FMOD studio. So it’s only when I’m in the game that the PC music is drowned out.

    I ‘ll try using the profiler window, though.

  • Brett Paterson

    When you use the profiler use ‘API capture’ button at the top, then you can replay the capture as if it were playing in the game. This would be a good way to compare.

    How are you comparing studio to the game? Just playing 1 sound? The game is likely to be playing a lot of sounds and studio one sound typically, or are you using the sandbox?

  • Micah

    I used the profiler and there is only one sound playing. It’s loud and kind of “base-y”, though.

  • Brett Paterson

    Is the game setting the speaker mode to be the same speaker mode that the project was set to? If it was, and used the same sound card it should be the same.

  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.