Answered
0
0

Hi there, I’m using FMOD studio and I’m having a few issues with the perforce plugin.

First, it does not save my source control settings at all. If I open the project through the startup screen or through File->Open, the project opens but the source control settings are all reset to default (if I go to edit->preferences->source control, the integration type is set to “None”, the File->Source Control area is all grayed out except “Browse for project”, which is also set to default).

So currently I can only open my project properly by going File->Source Control->Browse for project and have to type in my server, workspace and select the project.

Secondly, FMOD (or the plugin) isn’t checking out the files in .user/Metadata, so I have to manually check these out in p4v, otherwise I get an error saying I don’t have permission to edit those files.

Any advice is appreciated, thanks in advance.

  • You must to post comments
Best Answer
1
1

Hi,

In general, any folder within the Studio project that starts with a “.” (e.g. .user, .cache) should not be checked into Perforce as they contain user specific data. Once you have removed these folders from Perforce, you would also want to make sure the files are not read only. The Perforce settings are project specific, so you would need to set them at least once after opening the project.

  • Wilson C

    Thanks for the quick response, got perforce to ignore those files and everything is working perfectly :)

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.