Answered
0
0

I can’t seem to get any plugins built using fmodL64_vc.lib to be recognised in Unity. I keep getting the following error:

SystemNotInitializedException: FMOD Studio initialization failed :
Loading plugin ‘fmod_noiseL64’ from
‘C:/Users/rory/sourcecode/FMODUnity/Assets/Plugins/X86_64/fmod_noiseL64.dll’
ERR_FILE_NOTFOUND : File not found.

I believe the issue has to do with not having the correct dlls in the plugins folder, but I am pretty sure I’m following the correct protocol. Here’s the contents of my plugin folder:

c:\Users\rory\sourcecode\FMODUnity\Assets\Plugins\x86_64>ls *.dll *.lib
fmod.dll        
fmodl.dll 
fmodL64.dll       
fmodstudio.dll
fmodL64_vc.lib  
fmod_noiseL64.dll   
fmodstudiol.dll

fmod_noiseL64 is the plugin I’m trying to load, I’ve made sure to place fmodL64_vc.lib and fmodL64.dll into the folder too. Anything else I should be doing?

  • You must to post comments
Best Answer
0
0

Using DSPI::GetUserData and having to make FMOD itself a dependency of your plugin is not recommended.

  • You must to post comments
0
0

Thanks for clarifying this. I hope this will be addressed at some point in the future as I think DSP::GetUserData() is an absolutely essential method for anyone developing plugins. In the meantime, perhaps you could put a note about this in the documentation.

  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.