Answered
0
1

Hi guys. I’m new in this forum. I came here to make a question and i hope you answer because i can’t find a solution.

So I have a looping ambient sound. The problem is that when make it loop i always hear a click or a pop when the loop starts over. The thing is that the transition between the end and the beggining is suposably smooth. Check this screenshoot: http://prntscr.com/anysh9, and this one http://prntscr.com/anyskz (they are the same screenshot, one zoomed in and one zommed out).

In Pro Tools the sound loops fine, the only problem is here in FMOD. Any help would be appreciated.

  • You must to post comments
Best Answer
1
1

The screenshot to me looks like you have extended the sound and trying to loop it halfway through the second loop (which would likely pop). The little indentation at the top and bottom of the waveform shows where the original loop should end, so you should either trim the region back to that point, or delete the sound from the track and pull it out from the audio bin again. This will reset it to the original default length of the loop, and then you can add your loop region again.

  • frnacisco

    i’m afraid i couldn’t understand your explanation. What indentation are you talking about, and what is the point that you are referring when you say that i should trim the region back to that point?

  • frnacisco

    i’m afraid i couldn’t understand your explanation. What indentation are you talking about, and what is the point that you are referring when you say that i should trim the region back to that point?

  • Jesse Lyon

    In your second screen shot there is an indentation in the region near where your cursor is. Thats where the original file ends and should loop around to the start (assuming you edited the file in a DAW to loop properly). If you pull the audio file out of the audio bin again to the track, the region on the track should end there. At some point you must have extended the region on the track to make it longer then the original file.

  • You must to post comments
-1
0

ISN’T THERE A WAY TO CROSSFADE THE END AND THE BEGGINING OF THE LOOP IN FMOD?

  • Jesse Lyon

    You should create your seamless loops in a DAW like ProTools. FMOD isnt designed to be an audio editor like this.

  • frnacisco

    I do seamless loops in Pro Tools, but in FMOD the waveforms doesn’t match, therefore i hear a click

  • Thuan Seah Tan

    Hi frnacisco,

    Would you be able to send us a project with the event and sound demonstrating the project? You can send it as an attachment to support@fmod.org and provide a brief description of the issue in the email body. It would also help if you could let us know the build of Studio you are using.

  • You must to post comments
0
0

Try making your loop sounds start and end with a zero value. Make in PT inaudible small fades on start and end of your sounds…

  • frnacisco

    I already did that and i can listen to the pops.

  • You must to post comments
0
1

Hi frnacisco,

Just like to follow up on the pop and click issue. If you are still having a problem, feel free to send a demo project with the event and assets to support@fmod.com and provide a brief description of the issue.

  • Jesse Lyon

    I just came across this same issue and found the cause of the problem and solution….My loop was playing fine in FMOD during audition, no pops or clicks, but was popping on loop in game. The issue is due to the compression setting on that sample in the Audio Bin, Once I raised the compression quality to 100%, the pop in game went away. This must be due to a combination of sample rate of the file and the lower compression setting not allowing the sample to loop at the exact same point in the file.

  • You must to post comments
0
1

I just came across this same issue and found the cause of the problem and solution….My loop was playing fine in FMOD during audition, no pops or clicks, but was popping on loop in game. The issue is due to the compression setting on that sample in the Audio Bin, Once I raised the compression quality to 100%, the pop in game went away. This must be due to a combination of sample rate of the file and the lower compression setting not allowing the sample to loop at the exact same point in the file.

  • Jesse Lyon

    My mistake, the loop is only popping at lower sample rates with FADPCM compression. Vorbis 1% quality seems to be fine in audition as well as in game.

  • Thuan Seah Tan

    HI Jesse,

    I spoke to our guys, changing the sample rates for FADPCM shouldn’t affect the looping of the sound. Is it possible to send us a copy of the sound you were testing with? Is the popping only in game or when auditioning the event?

  • Jesse Lyon

    Oddly, I can no longer get it to pop, either during audition or in game, even if set to 4kHz FADPCM compressed. Cant explain it, but I will email you the sample to see if you can recreate the issue.

    Thanks!
    JL

  • Thuan Seah Tan

    Hi Jesse,

    We did managed to reproduce the issue locally using your sample. The issue should be fixed in our next 1.08 patch release.

  • Thuan Seah Tan

    Hi Jesse,

    Just a quick update, the issue should be fixed in FMOD Studio 1.08.09.

Showing 5 results
Your Answer

Please first to submit.