Answered
0
0

Hi

Unity Version 5.5.0p1
FMOD Version 1.09.05

In our game we have a number of videos that play in a number of different scenes using VideoPlayer in Unity.
In the front end GUI before FMOD is initialised the video plays fine however in game after FMOD is initialised if we try to play a video we get the following:

SDK Assertion Failure: ‘m_totalUsed!=nn::audio::AudioOutCountMax’ in AddPair() at pid=135, tid=2086(MainThread)
D:\Home\teamcity\work\d0f21731695d54c4\sdk\Programs\Eris\Sources\Libraries\audio\shim\audio_AudioOutShim.cpp(47)
Opening too many Audio Outs, can only open 2

I’m assuming that FMOD is using the 2 Audio Outs as we have a number of sound effects and music playing at this point.

Is there a way that we can configure FMOD so as we can play videos with VideoPlayer at the same time as playing music and sound effects?

  • You must to post comments
Best Answer
0
0

Each FMOD System, if using the default output mode, will use one “Audio Out”.

It is possible that the built in Unity audio is using the Audio Out, if it is an option for you it can be disabled via “Edit->Project Settings->Audio->Disable unity Audio”.
This should free an out for the VideoPlayer.

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.