1
0

I’m having a weird problem where my scatterer sounds on my ambience events in FMOD are playing correctly, scattering about, but then in Unity they’re fixed to the center as mono. It seems like this issue is with Unity, but I’m not sure. I’ve deleted the 3d panner in FMOD, and the speaker mode in both fmod and unity is stereo. The channels on the events themselves are stereo as well. If anyone has any advice that would be really helpful! Thanks!

  • You must to post comments
0
0

Hello Emily,

By default a Scatterer Sound module will use a 3D Panner to play sounds listed in the module playlist. So even if you have removed the 3D Panner from the Master track it will still play as a 3D sound, emitting from a particular source (game object). This results zero attenuation if the sound is playing at the same position as the player.

If you set the Min & Max Scatter Distance setting on the Scatterer Sound to 0 Min and 0 Max, this will put it into a 2D mode and should give you the stereo effect you’re looking for.

The Scatterer Sound is working as intended but we will try to improve the usability of it at a later date. In the meantime please use this workaround.

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.