Answered
0
0

Hello, guys. As title says, I have some troubles playing back multiple sounds. I have mp3 music playing and if I start my sound effect during it, the music gets almost silent until sound effect ends.

I use ‘Mixvibes U-Mix44’ sound device wich has two outputs (for 4 speakers in sum) and to send sounds to different speakers I use this function:
sndChannel->setMixLevelsOutput(1.3f, 1.3f, 0.0f, 0.0f, 3.0f, 3.0f, 0.0f, 0.0f);

Hope this information will help you to help me :)

P.S.: Sorry for my awfull English, hope you’ll understand me

  • You must to post comments
Best Answer
1
0

Hi,
check your sound settings, there maybe a ‘loudness equalization’ turn on in the ‘enhancements’ tab of your soundcard properties.

The fact that you’re going over 1.0 for your levels, if a compressor/limiter is involved, is going to push the whole mix down, which will make your music sound like it is getting quieter.

Normalize your levels down to 1.0, not 1.3 or 3.0. If the sound effect isnt loud enough compared to the music, consider lowering your music volume first.

  • You must to post comments
0
0

So I should use soundcard’s built-in ‘gain’ instead of writing 1.3, 3.0, etc. in FMOD, right?

  • Brett Paterson

    why set it so loud? You normally wouldn’t be setting anything above 1.0 (unless your source data is really quiet), keep everything under 1.0 and you wont have any soundcard interference.

  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.