Answered
0
0

Hi,

I experience undesired behaviour with default device choice FMOD makes to output sounds.
When the default Windows audio output device is set to something other than Rift, e.g. headphones, there will be no audio in the experience. How can I force FMOD to play through the rift? The ue4 default sound engine always outputs audio through the rift when connected.
We use both of the sound engines in our project, and it happens only the non-FMOD sounds are played correctly played. It is even more disturbing than no sound at all!

  • You must to post comments
Best Answer
2
1

I updated FMOD and did not realize a new option was available in the plugin configuration. I set Initial Output Driver Name to Rift Audio and now everything works a charm.

  • Rick Saada

    Thank you sir! That just saved me a lot of pain.

  • You must to post comments
0
0

Are you getting any errors or warnings in UE4?

Just double check the Oculus plugin has been setup correctly as mentioned:
http://www.fmod.org/documentation/#content/generated/engine_ue4/plugins.html
&
http://www.fmod.org/documentation/#content/generated/engine_ue4/deployment.html

  • You must to post comments
0
0

Everything it setup correctly, and there is no warnings in the logs.

Here is a screenshot of my Windows 8.1 sound panel to let you check if you can reproduce the issue. https://framapic.org/6zyIJrqrtuOG/qJCA774fQjIl.png
Realteak Soundcard is set as default sound device and Rift as ‘Ready’. Everything else is disabled.

  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.